503 error for a link through search engine, but direct fetch OK

#1

We have a pretty odd issue I’ve never run into before.

If I click on “some” of the links for our website through a search engine (google, bing) I get a 503 error, but if I go to the url directly the site works correctly.

Through webmaster tools, google does not flag the error the last time they crawled it.

Example.

Here’s the url to the article: https://www.fiercebiotech.com/biotech/fda-conflicted-lilly-and-incyte-s-refiled-baricitinib

When you load the above in your browser it loads ok.

The article is the topi link when the article is discovered through keywords:
https://www.google.com/search?ei=50_IXNHgGeKW_QbV3K3oCw&q=baricitinib+Lilly+fiercebiotech&oq=baricitinib+Lilly+fiercebiotech&gs_l=psy-ab.3...6777.9354..9535...0.0..0.123.1147.11j2…0…1…gws-wiz…0i71j35i39j0i22i30j35i304i39j33i299j33i160.nz4U40lQFUo

When you click on the link through the search engine you get a 503 response.

These are the response headers when we get a 503:
accept-ranges: bytes
age: 0
cf-ray: 4cfae6061c27d36a-LAX
content-type: text/html
date: Tue, 30 Apr 2019 16:30:08 GMT
expect-ct: max-age=604800, report-uri="…removed due to new user limit…"
last-modified: Thu, 20 Dec 2018 01:11:29 GMT
server: cloudflare
status: 503
via: varnish
x-cache: MISS

Things we’ve tried:

  • putting the domain in development mode
  • clearing the application, varnish and cloudflare caches multiple times (in that order)

Anybody run into this kind of an issue before? Any ideas?

#2

Can you post a screenshot of the error you receive?

I shortened your Google link a bit -> https://www.google.com/search?q=baricitinib+Lilly+fiercebiotech - I assume you still get the same error. I am afraid I can open the page just fine via Google though.

#3

Thank you for taking a look sandro.

I attache a snapshot of the 503 response and the headers.

Try this link:

#4

That is an error coming straight from your site.

However the link there is not https://www.fiercebiotech.com/biotech/fda-conflicted-lilly-and-incyte-s-refiled-baricitinib but https://www.fiercepharma.com/keyword/eli-lilly instead.

Different link and an error from your site. I am afraid thats something you need to fix on your server.

#5

Oddly, both of those links load fine on my machine if I load the link directly via the browser. I’ve tried Chrome Incognito and firefox.

Steps I take:

#6

The first link always loaded fine, the second one didnt. However now it does, directly and via Google. Maybe a temporary glitch on your server.

#7

Thank you for your help @sandro

It was an application issue.

1 Like
closed #8

This topic was automatically closed after 14 days. New replies are no longer allowed.