502 Gateway Error


#1

Hi! My website does not work with cloudflare. I’m using cloudlinux + litespeed server. When I resumed my website on Cloudflare it returns 502 gateway error. When I paused it again, it works perfectly. Did you experienced any similar things?

P.S: I’m transferring websites to new server (cloudlinux + litespeed). In the old server (centos7+nginx) all websites worked perfectly.


#2

https://support.cloudflare.com/hc/en-us/articles/218378978-What-should-I-do-after-seeing-a-502-or-504-gateway-error-on-my-site- might fix your issue.

If it doesnt, post your domain and any additional useful details.


#3

Hello. I already try that solution. In fact, according to Cloudflare there is a 502 error but when I redirect my domain directly to host or pausing on cloudflare website works as perfectly. I believe problem is in the Cloudflare. I contacted with my hosting company many times and they confirmed me there is no problem with server.

grandmount.org - Cloudflare OFF
bkvideography.club - Cloudflare ON

Both websites DNS redirected to Cloudflare.


#4

It usually isnt :wink:

In your case for example you are not even going through Cloudflare but use only DNS. Your domain resolves to your actual host.


#5

So the issue is not with grandmount but with bkvideography?

I dont get a 502 for the latter, be it on HTTP or HTTPS. HTTP works and HTTPS fails straight away with a TLS error. When did you add the domain?


#6

I’m getting following error. Browser waits about a min than gives following error. Before this screen, it gives Cloudflare 524 a few secs than it returns to Cloudflare 502.

If I stop Cloudflare services, it works perfectly as well. Therefore, I’m considering conflict between litespeed and Cloudflare services. I’m java programmer my web programming-server info is limited so I can’t be sure what’s wrong with it. Best regards.

P.S: Cleared browser cache and ipflush. Already done. Same result.



#7

In your case it does not seem to load at all. For me it does load on HTTP at least.

http://sitemeer.com/#bkvideography.club also shows some failures, however https://www.cloudflarestatus.com/ does not list any ongoing issues.

Can you post the output from http://bkvideography.club/cdn-cgi/trace?


#8

fl=71f290
h=bkvideography.club
ip=217.131.88.201
ts=1536187349.759
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36 OPR/55.0.2994.44
colo=FRA
spdy=off
http=http/1.1
loc=TR
tls=off
sni=off


#9

Another funfact. Website opens with Opera VPN. But I close the VPN, website agains give the same error. I am losing my mind. There is no such mind-blowing errors in Java :smiley:

My country: Turkey. I am now considering maybe some cloudflare services are banned?


#10

The output above was via VPN, where it works?


#11

My mistake. I updated it (without VPN results).

OPERA VPN:

Europe: Working
Asia: Working.
Americas: Working.
Turkey (noVPN): Not working.

Note: Website isn’t banned in Turkey.


#12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.