502 Error when enabled cloudflare


#1

Hey guys i am using cloudflare from the begining and from the last 3 days i am getting 502 error on my website.
I contacted my hosting staff and they asked me to disable cloudflare to see if it fix the problem and when it was paused there were no errors at all.
When i enable cloudflare again again the error was back from multiple locations.
I am using free cloudflare strict ssl and changed it to flexible but no luck
Also i purged the cache and checked it back but again the error was there.
when i disable cloudflare i am not getting any 502 error but this was from the last 3 days .
Can any one help me as my server is not the issue here?
This is my website
https://aimforbig.com


#2

This was the error i was getting constantly when cloudflare was online…

Error 502 Ray ID: 44a46f863dbd34b2 • 2018-08-14 15:25:42 UTC

Bad gateway

If i disable cloudflare every thing went back to normal no errors at all


#3

Same happens for me that’s why i switched from cloudflare back to normal


#4

Bad gateway usually indicates Cloudflare can’t reach your origin server. There’s likely some firewall blocking Cloudflare IPs (maybe your server host? I imagine some hosts don’t like Cloudflare’s free SSL).

Check with your server host and see if they can provide assistance, also a good idea to open a CF support ticket and they can look into why CF is getting the error.


#5

I contacted host again and asked her. She told all the ips from cloudflare are white listed.
I also temporarily disabled cloudflare paused it and checked back my site no errors at all so i dont think the issue is from the server as its working perfectly fine when i am not using it


#6

It looks like you got it fixed.

$ curl --head https://aimforbig.com
HTTP/2 200 
date: Wed, 15 Aug 2018 09:57:01 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=d6c9f8111ab533194340ccb600998a8d01534327021; expires=Thu, 15-Aug-19 09:57:01 GMT; path=/; domain=.aimforbig.com; HttpOnly
x-frame-options: SAMEORIGIN
vary: User-Agent,Accept-Encoding
last-modified: Tue, 14 Aug 2018 15:44:40 GMT
cache-control: max-age=0, no-cache, no-store, must-revalidate
expires: Mon, 29 Oct 1923 20:30:00 GMT
x-xss-protection: 1; mode=block
x-content-type-options: nosniff
pragma: no-cache
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 44aacb6d6fca6c16-SJC

#7

Sorry to say no i am getting the same error again and again when i open plugins or pages or posts
Its still not fixed couldn’t find the exact problem as hosting staff were unable to find logs
when disabled cloudflare every thing works normally without any error


#8

I’m sorry to say all I get is status code 200 OK
https://tools.keycdn.com/performance?url=https://aimforbig.com/about-me/
However your site seems a little slow to respond sometimes maybe there is some timeout reached from Cloudflare to the origin. Possible rate limiting or something on the origin host?

$ time curl --head https://aimforbig.com/about-me/
HTTP/2 200 
date: Fri, 17 Aug 2018 11:32:32 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=d405627445ccc7a6ac086298b4c79416a1534505552; expires=Sat, 17-Aug-19 11:32:32 GMT; path=/; domain=.aimforbig.com; HttpOnly
x-frame-options: SAMEORIGIN
vary: User-Agent,Accept-Encoding
last-modified: Fri, 17 Aug 2018 10:46:00 GMT
cache-control: max-age=0, no-cache, no-store, must-revalidate
expires: Mon, 29 Oct 1923 20:30:00 GMT
x-xss-protection: 1; mode=block
x-content-type-options: nosniff
pragma: no-cache
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
server: cloudflare
cf-ray: 44bbd21799666c16-SJC

       0.86 real         0.04 user         0.00 sys

#9

This topic was automatically closed after 14 days. New replies are no longer allowed.