502 error only on cloudflare suddenly (pausing cloudflare fixed it), no setting changed

yes, the problem is yesterday , after my hosting shows 5 0 2 error (pressumably because the space is full), I increase the quota allocation for it, but the 5 0 2 error page still persist from cloudflare indicating that my host still return 5 0 2 error.

I tried, purging the cache, and change lots of other setting but to no avail, still shows cloudflare 5 0 2 error saying my hosting return 5 0 2 error.

When I pause cloudflare, my site is working as usual, even my hosting provider keep saying everything is good on their end, so check with cloudflare.

even after few hours of changing setting, purging cache in my site, activating / deactivating plugin in my site (it’s a wordpress site), etc, still no difference. using cloudflare it’s 5 0 2 error, but pausing cloudflare make the site runs as usual.

in desperate attempt, I delete the site from cloudflare dashboard, and re-create it again (of course with same settings, same dns information, etc), but now it’s showing SSL error instead.

error:14094410:SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure

which is strange, I didn’t change any settings at all. just deleting & re-adding the site to cloudflare with same settings, why the error change? but still error.

Strange enough, I meddle with some ssl setting, re-generate certificate, etc, even changing ssl/tls setting in cloudflare from no encryption, flexible, full, full(strict), anything, purging cache, still showing that ssl error, but when I pause cloudflare from the site, viola, the site work again as usual, no ssl error.

Once again my hosting provider says that if everything works fine (ssl, not showing 502 error) without cloudflare, then ask cloudflare.

so I gave up, I pause cloudflare, so the site run as usual without cloudflare. so I let it sleep for a day (where I got blocked from replying your comment yesterday).

Today, when I attempt to reply to you to let you know, I turn on cloudflare again, and it just… work? I didn’t change any settings at all. just pausing it for a day. So, it may be cloudflare glitch on cache? or something? I’m not sure, but now the site works normally again with cloudflare.

Note that from the beginning till the end, after changing lots of setting and it doesn’t work, I revert it back to the original setting. so bottom line, there’s no setting changed at all, no dns change, but it was not working yesterday, but working now.