502 error only happens when activate CF proxy

www.ibitt.co all works fine when I set CF to DNS only. (proxy off)
if i try to activate CF orange cloud proxy I get 502 bad gateway cloudflare page.
I have added the CF ip address ranges to my configserver csf ignore table in WHM

Please help!

Please help…

Does your server IP address end in 90? If so, that error comes straight from your server

hi sandro,

yes the server Ip ends 90
sometimes i get the nginx 502 error and sometimes i get the CF 502 page
but this only happens when i activate CF proxy. Without using CF proxy the site is perfectly accessible.
so what could be the cause?

hi, any suggestions please?

As that error comes from your server, you need to check and fix that on your server.

obviously i cannot do that or I would not have spent all this time to ask you for the support!

As I said, the error only happens when i turn on CF proxy on cloudflare.com so the error is caused by your side not my server…

Can you give me any solutions instead of just telling me to go away?

I am not telling you to go away, just that your issue is somewhat beyond the scope of the forum here, as the forum here is for Cloudflare related issues and your issue is about your server configuration instead. You best take that to e.g. StackExchange.