502 error after adding cloudflare

Hello,

I am getting a constant 502 error on my site after adding cloudlfare yesterday.

Servers ufw settings:

https://gyazo.com/d34136a0736c9c8ea9cd3bfdb7a903df

Domain: https://decease.co.uk

Thanks!

I’m getting a 521.

  1. If you set DNS here to :grey: for that hostname, does it still happen?
  2. What SSL setting are you using? (Flexible or Full?)

I’ve set it to :grey: and now it doesn’t load anything. now it loads the page perfectly fine.

Also, it is set to Full

I’ll leave it set :grey: till you get back to me.

Also heres the direct server so the page is up: http://vps636649.ovh.net/

You server doesn’t respond to HTTPS requests

ERR_CONNECTION_REFUSED

Make sure you have a certificate installed, that Port 443 is allowed by your firewall and that our webserver is configured for https.

1 Like

As @MarkMeyer pointed out, your server doesn’t support SSL at this time, so you can’t use the fully encrypted Full mode.

Is it supposed to be the default Apache setup page?

Here is my 000-default.conf to enable https:


https://gyazo.com/e94da26c168d963e576bc7dc650b098b

Here is my firewall:


https://gyazo.com/001d8370c583b17fda7da25cfcd8f036

Why isn’t https working?

That’s a question best answered at Stackoverflow or an Apache forum. Once you get that part up and running, you’ll be ready to move your site to Cloudflare.

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.