502 Bad Gateway


#1

Hello.
My website https://www.tribeccasystems.com experiences a 502 Bad Gateway error every once and a while.

This looks really bad when I am asking a customer to visit and it comes up periodically.

Please advise. I am using NameCheap / CloudFlare.

Thank You!


#2

Hi @ericsimankowicz, I visited the site several times and cannot replicate the 502 error. Usually, a 502 error is passed from the origin. Do you know if your customers were seeing a Cloudflare-labeled page? (You can see the Cloudflare page in this doc, https://support.cloudflare.com/hc/en-us/articles/218378978-What-should-I-do-after-seeing-a-502-or-504-gateway-error-on-my-site-) If they’re not seeing the Cloudflare page, it could be the Cloudflare ip is blocked or there is some issue with the origin.


#3

I am receiving this error. Please see the attached image.


#4

Ah, thank you. Yes, that looks like an error passed from the origin server. I visited that page and can see mixed content issues, but still not the 502 -> On the Crypto tab of the Cloudflare dashboard, turning on Automatic HTTPS rewrites should address that. As for the 502, can you try setting Cloudflare SSL to Flexible?


#5

Settings changed. Thanks so much for trying to help.


#6

Of course, now I see the 520. Couple of suggestions, first I’d get a ticket in queue with support AT cloudflare DOT com. Next, can you see if your host shows errors in their logs? At same time I’d ask if they’re blocking cloudflare IPs (i don’t have the link to them handy, it will show up in a search.


#7

Thanks so much, I will do those things today.


#8

Did you see the error or are you going off of the image?


#9

Here are the two errors that I see… do these help at all?
https://pastebin.com/0Xsgtgm0


#10

I had the same issue… Try disabling other caching service or CDN servers other than cloudflare. Also Try disabling Rocket loader