502 bad gateway error


#1

Dear All. I have found 502 error in my domain since last day. any one can give a help for me. That domain is wheedeal.lk


Bade gateway Error 502
#2

Your web server isn’t properly responding to Cloudflare.

Does it work if you go to the Cloudflare Dashboard’s Overview page and Pause Cloudflare (under Advanced)?


#3

I have hosted and using my other domain in cloudflare in same server. this hapen only this website. can you help me to resolve this problem…


#4

I have add my domain to cloudflare. After that I got below err. Bade gateway Error 502. Any one can help me to resolve this problem…


#5

You can check now on wheeldeal.lk. Still there that error…


#6

Any one can help me to relove this my site error. I am waiting your replay. Please help me…


#7

Same problem here…


#8

Hello. I have had this issue for over a week… here is what I did to resolve the issue.

Obtain the name servers or “A” records information needed by your web host provider. Input those to cloudflare.

If your domain registrar is different, check your domains registrar records that they are pointed to cloudflare.

In Crypto tab of Cloudflare, if SSL Flexible is not set, use Flexible.

My issue was due to the SSL secure being set. Once I changed that to Flexible it worked.

Also worth mentioning, when changing Name Servers or A records, patience is important because it CAN take more than an hour depending on your Web Host, Registrar, and Cloudflare connections to each other, which is out of our control.

Hope my experience helps someone else.

Note I my website host is awardspace. My registrar is goDaddy.


#9

Hi @wheeldealseo, I see a lot of mixed content errors on the site. On the Cloudflare dashboard, under the crypto tab, the Automatic HTTPS Rewrites option may fix most or all of those. Also, the tips from @Chris79 is a great list to check.


#10

@wheeldealseo had the same problem. The problem started when I added CF dedicated SSL. Tried @Chris79 solution andi it solves my problem (thank you for sharing!).


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.