502: Bad Gateway Error when trying to connect to HTTPS site passed through Cloudflare Tunnel


I have a couple of domains I wish to pass through the Cloudflare tunnel. I managed to get all of the HTTP sites to work, but I cannot get any of my HTTPS sites to work. They always load into a 502: Bad Gateway error even though the local address works and I have TLS verification disabled. I have also tried enabling HTTPS2, disabling chunked encoding, and setting the proxy type to “” all of which haven’t worked.

Any ideas?

Hi Ralph. Try gateway, policies, HTTP.
Create a policy, expression, domain, is, x.y.z, do not inspect. Can also point to a list if multiple.

Came across it when I found partial workaround for when Warp LAN IP range conflicts with office and I got a secondary IP working down tunnel. Yet to solve DNS for that without hosts file entry but hopefully close.