502 Bad gateway error after SSL

dash-crypto
#1

My blog ( becasuse of the problem ı don’use cloudflare nıw).
I’m getting started with running Discourse on a Digital Ocean Ubunto 14.04 LEMP droplet, alongside WordPress. Everything was running fine, using the SSO WordPress plugin for Discourse. Discourse is in a subdomain.

I subsequently installed a wildcard SSL. WordPress is running fine, but when I try to connect to Discourse I get a 502 Bad gateway error. I have tried editing the /etc/nginx/sites-enabled/default file and /etc/nginx/conf.d/discourse.conf with no success. This isn’t really my area and I can see I’m going to make things worse if it keep tinkering…

#2

Could you post your configuration? Discourse has specific setup instructions for nginx as a reverse proxy:

Also note that while you can run discourse as a subfolder, this is NOT recommended

If this all sounds odd and strange to you we strongly recommend you avoid this setup.

1 Like
closed #3

This topic was automatically closed after 30 days. New replies are no longer allowed.