502 after completing cloudflare steps to CDN activation

I made nameserver changes at godaddy, then completed the steps in cloudflare like adding A record, etc. Everything indicated success however the website returns a 502 error, but there was no issue with website until I setup cloudflare and there is no issue with other websites on same server, so it seems to be I’m missing something on cloudflare, any help is appreciated.

This is an issue with contacting your origin server. Make sure your IP is correct and firewall can accept requests.

You should pause Cloudflare and get it working with SSL before unpausing Cloudflare again.

To “Pause” that seems to mean to put it in Developer Mode, I’ve tried that and still get 502. What doesn’t make sense to me is why Cloudflare would not provide better directions in having a successful activation of their service, there is nothing unusual about my setup, it’s the same as thousands of other wordpress sites with linux hosting, I do use site compression but I’m not sure why that would be a problem. It makes we wonder why I should jump through hoops to use the service.

Developer Mode is not the same a Pause. Pause is in the lower right corner of the Overview page for your domain at dash.cloudflare.com

I don’t think I saw a description of the process you went through, but was your site already working with HTTPS before you added it to Cloudflare?

Yes, it was, I even have a plugin that forces content all to https

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.