5000ms+ wait time with cloudflare


#1

Hi guys, a month ago I setup cloudflare on my website with the thought that after I set it up it’s all perfect and haven’t given it much thought since.

I always felt like the site was a bit slow but I ignored it as I wasn’t yet optimizing my content etc but today, when I ran a test my wait time is 5600ms+ and that’s waaaay too high.

I have to admit I’m a bit of a pleb and don’t really know what I setup wrong, I thought if I just followed the guide that says “Get fast load times with cloudflare” it will all just be good haha.

What could I be doing wrong? Feel free to ask for any details.


#2

That is most likely an issue on your server. Whats the domain?


#4

Wordpress, of course :slight_smile:

It is the usual problem that the initial page load takes very long. Only to load the HTML document it took me about 2.3 seconds. If you have concurrent requests that can go up by a lot -> http://sitemeer.com/#https://impeccabledestinations.com

The only thing Cloudflare could do here is cache everything, including HTML, in which case the page wouldnt be served by your server any longer but by Cloudflare, until it expires in Cloudflare’s cache. That might be a solution if your site does not change often, should it change however you’d served outdated content.

Your best bet is to make sure you Wordpress setup works better. There have been quite a few discussions here on the forum, so you could use the search respectively also search online.


#5

Oh so you’d say wordpress is the problem? That’s a bit weird considering so many website are on wordpress with wait times a lot lower than mine. Will look into it. Thanks


#6

These issues are quite common with Wordpress. If you do not have a proper configuration respectively installed too many plugins there is a good chance your site will grind to a halt.


#7

Well that’s a huge hint considering I have about 40 plugins lying around. Will try to reduce that to below 10


#8

The number of plugins is not necessarily the reason, but with 40 there is a good chance at least one of them slows everything down. It really comes down to your specific setup.


#9

It’s always a good idea to limit plugins for both performance and security of your site. Be sure to check if the remaining plugins are still supported! You can do this by going to your WP Dashboard > Plugins then select “View Details” of each plugin.


#10

Yikes, I just deleted about 25 plugins and still the same results on your site. Checked another wordpress site in the same niche with cloudflare and his “First receive” is 100-200 while mine are 11000-12000. I must be doing something painfully wrong haha. I’m not expecting 100-200. to me even 1500 would be usain bolt fast.


#11

Are you using any WordPress caching plugin? I see you are using Autoptimize, which is a great tool for optimization, but without a page caching plugin, every visit, including every visit by Cloudflare, will request that your server regenerate the page. If you are already using one, make sure to visit its config page to check its settings. If not, there are several caching plugins you can try (Autoptimize works well with WP Super Cache), and they will certainly speed up things a lot. After you have a caching plugin on your server, then you may consider a page rule in Cloudflare to “cache everything”, as mentioned by @sandro to reduce even more the loading time.


#12

Thank you so much guys for all your help! My wait time is around 200-300ms!

I can’t believe how stupid I was having 40+ plugins and for some dumb reason deleting my cache plugin. I think I was under the impression cloudflare has that covered. You live you learn haha.

Thank you again and good luck with everything!