404 - Not found with HTTPS

Good morning everyone, through this Forum I have solved many problems and I am grateful to anyone who wants to give me a contribution to solve this problem.

I was able to seamlessly integrate Cloudflare DNS with my site with Siteground Hosting.

They have in fact propagated perfectly now.

I just have one problem, it seems like my site like “https:” is not working.

I tried doing a scan with GTMetrix.

When I do it with HTTP it works perfectly and gives me excellent results.

However, when I do it with HTTPS it gives me a 404 error.

I checked on Siteground and Cloudflare and all settings leading to https are entered correctly.

On Wordpress the site is indicated as https:// - I have activated https forcing both from the Siteground tool and via Cloudflare.

I really don’t know how to solve this problem, it’s the only flaw in an otherwise very well structured site.

Who could tell me how I can solve this problem?

Thank you very much!

(Attached GTMETRIX screen scan of the site in http and https)

A site loads for me when I connect over HTTPS.

1 Like

It’s not a http/https issue, its a spintadigitale.com / www.spintadigitale.com problem.

https://spintadigitale.com is ok, https://www.spintadigitale.com gives the 404.

Make sure your hosting is set up to handle both in the same way and that your Cloudflare DNS is set such that www is CNAME of spintadigitale.com


Wow… so if that were the case I was worried for nothing!

At this point I ask you for confirmation…

These are the DNS settings of Cloudflare and Siteground… do you find any inconsistencies?

The A record for www needs to be set to the same as the others. If you use FTP and SSH those records should be set to DNS only (unproxied) as those services can’t be proxied through Cloudflare.

1 Like

Thank you!
So from Siteground’s Sitetools I will have to modify:

A - www . site. com . making it point to (it is now at
A - site . com . making it point to (it is now at

While on Cloudflare… I would have to uncheck “Proxies” in the DNS, Records section of all the records with the active proxies function.


As you may have understood, I’m not an expert… but I’m trying to learn :slight_smile:

No, just for FTP and SSH. Otherwise Cloudflare’s protections won’t be applied to your site.