404 Not Found after switching to Cloudflare Nameservers


#1

Hey guys,

I run www.bavaerials.de and wanted to use cloudflare. I set the account up, switched Nameservers with my hoster and after two hours I now get 404 Not found for my domain. I had some strange DNS Records from the scanner. I’ve tried with some minimum settings but no luck. Somehow email does work for the domain.

Anyone here who can help me out?

Help is highly appreciated!


#2

Hello there. You don’t appear to be using Cloudflare nameservers. Have you changed them at your registrar?


#3

Hi there.

I did set them up at my registrar.
Just had the service paused but that shouldn’t affect with the nameservers.

If I check this I see the Cloudflare Nameservers: https://www.whatsmydns.net/#NS/bavaerials.de


#4

Your www hostname is still pointing directly to your webserver, so provided you imported the correct data from the old DNS server, nothing has really changed.

Nameservers look correct:
$dig +short ns bavaerials.de nitin.ns.cloudflare.com. isla.ns.cloudflare.com.

The domain root is still your origin (I’ve obscured the IP address)
$dig +short bavaerials.de 81.xxx.yyy.zzz

You should compare the DNS records from your old provider with the account you created on CloudFlare. If the site worked on the same IP before you changed your nameservers then something else has changed.

(As I was looking at this I think you clicked the Orange cloud button, but I was getting 404 from the Strato IP address also).


#5

Hey yes I see now that the DNS is propagating and you are using Cloudflare NS. I think something may be up with your origin server…


#6

The problem is I can’t access my old DNS settings as these were deactivated as I switched Nameservers. The scanner imported many Records which I don’t understand and don’t know if I need them.

These are my current settings:

;; MX Records
bavaerials.de.	300	IN	MX	5	smtpin.rzone.de.
*.bavaerials.de.	300	IN	MX	5	smtpin.rzone.de.

;; TXT Records
_domainkey.bavaerials.de.	300	IN	TXT	"o=~\; t=y\; [email protected]"

;; SRV Records (Service locator)
_autodiscover._tcp.bavaerials.de.	300	IN	SRV	0			100 443 autoconfigure.strato.de.

;; CNAME Records
k1._domainkey.bavaerials.de.	300	IN	CNAME	dkim.mcsv.net.
autoconfig.bavaerials.de.	300	IN	CNAME	autoconfigure.strato.de.
www.bavaerials.de.	300	IN	CNAME	bavaerials.de.

;; A Records (IPv4 addresses)
wp.bavaerials.de.	300	IN	A	81.xxx.yyy.zzz
bavaerials.de.	300	IN	A	81.xxx.yyy.zzz

;; AAAA Records (IPv6 addresses)
bavaerials.de.	300	IN	AAAA	2a01:aaa:bbb:ccc:ddd

#7

Do you recall your old NS records? I think the welcome email from CF has them, or get them from the API. It would be worth double checking that the basic records match, and they may still be available directly from the old NS.

Your origin returns nothing, so something up with there.

$ curl -I -H "Host: bavaerials.de" http://81.xxx.yyy.zzz/ HTTP/1.1 404 Not Found


#8

I do have the old ones from the email. Do they help in any way?

docks10.rzone.de
shades02.rzone.de

I also tried the curl and just got the stupid 404 I`m seeing since hours :frowning:


#9

Your web server (Nginx) is returning the 404 and nothing is wrong with DNS. This is probably a server side issue. What if you disable CF (gray cloud) without touching your server?


#10

I think the issue is that I’m on a shared hoster with many other sites. I believe the requests get routetd through CF Nameservers and come back to my hoster from a different IP. That’s why I get the 404 as CF apperently doesn’t send host-header with the request. I called my hoster but they are all clueless and say I’m the first who wants to use this service.

I was thinking it has something to do with one of these DNS entries:
autoconfig.bavaerials.de. 300 IN CNAME autoconfigure.strato.de.
_autodiscover._tcp.bavaerials.de. 300 IN SRV 0 100 443 autoconfigure.strato.de.

Disabling CF with the grey cloud also has no effect. The requrests still comes from an IP the hoster can’t match.
Also I found this article about mod_cloudflare which I’m unfortunately not able to install as I have no acess to the apache directly: https://support.cloudflare.com/hc/en-us/articles/200170916-Why-should-I-install-mod-cloudflare-

So, I think I will have to give up and set my nameservers back to normal and no Cloudflare with my hoster Strato!


#11

You don’t have entry for autodiscover.tcp.bavaerials.de, try adding one in CF panel.


#12

Can you please tell me how I should do this?


#13

In your CF panel add:

autodiscover.tcp.bavaerials.de pointing to autoconfigure.strato.de


#14

But isn’t this exactly this record I posted above:

_autodiscover._tcp.bavaerials.de.	300	IN	SRV	0			100 443 autoconfigure.strato.de.

As far as I can tell it’s already there. Please correct me if I’m wrong.


#15

You didn’t mention where that entry is and I assumed it was the old DNS entry since at the time autodiscover.tcp.bavaerials.de points nowhere.
BTW the two DNS entries show your case is not a regular website and may need access to special ports.


#16

Sorry if I didn’t make myself clear there. The post above with the records is what the DNS Scanner found and what I had set initially on CF. Unfortunately, these settings don’t work. Right now I’m stuck with no idea on how to get it working. I’m on a shared hoster with not much knowledge of DNS. Would have loved to use CF but now I think I have to revert my Nameservers back to standard as my site has been offline for more than 24 Hours. I called my hoster and they were absolutely not cooperative in this. All they said was that by using different nameservers I gave all control away. What a bummer…


#17

Wait… something has happened. My site is now available. I did revert the changes by my hoster back to the standard nameservers and hour ago but I’m not sure if what I see now is via CF or my Server.


#18

Your website is up and working and protected by CF. Congrats.


#19

Your site appears to be running through Cloudflare as of this moment :orange:


#20

Thank you so much for your help guys! To be honest I have no idea what I did to make it work. I will investigate this further and let you know if I find the reason. Thanks again!