404 Error when enabling Proxy

Site works fine with Cloudflare proxying disabled. Cloudflare SSL settings is set to “Full” and site work with HTTPS when proxying is disabled.

When i enable proxying, i get 404 error.

[email protected]:~# curl -i https://trend55.com/
HTTP/2 404 
date: Wed, 26 Jan 2022 04:27:15 GMT
content-type: text/html; charset=us-ascii
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
set-cookie: __cf_bm=UkJjfdLArgb9xksn99Sw2vBVo.RSZ0HpsQbCCFz.N_4-1643171235-0-AfL6sdvg4hOdTcCST5dn3ltp2Gfk3vArOKyi3eSbLnPPnkHvqIHV0gyBxhUEsMkmI0921oOn2O/eGN4gSXeTj/Q=; path=/; expires=Wed, 26-Jan-22 04:57:15 GMT; domain=.trend55.com; HttpOnly; Secure; SameSite=None
server: cloudflare
cf-ray: 6d36fcddcf03593b-AMS
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Not Found</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Not Found</h2>
<hr><p>HTTP Error 404. The requested resource is not found.</p>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6d36fcddcf03593b","token":"367290c3b9fb45498330cac221ec3ed0","version":"2021.12.0","si":100}' crossorigin="anonymous"></script>
</BODY></HTML>
[email protected]:~# 

I created a subdomain for this domain on same server, it worked fine with out errors.

I stopped apache on backend web server, instead of usual backend down error, i still get same 404 error. I don’t see any entry in apache access log of the backend server.

I changed backend server IP to another server IP address (188.40.131.92), i still get same 404 error. If i used this IP on a subdomain, it works. Exanple https://ok.trend55.com

I deleted the site from Cloudflare, created it in another Cloudflare account, still same thing happens.

Look like Cloudflare is producing this error with out even reaching out to backend server.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.