404 Error on some pages even though pages exist


I am getting 404 Errors when accessing a couple pages (3-4 pages out of a couple hundred) on my website when they are not including “www”. I can ping the domain no problem.

I’ve asked people from Malaysia to Nigeria and it works for them. I’ve used the browser on the server and these pages work on their too since its located in another country. About 99% of these 404 errors on these pages are coming from the US. I’ve tried multiple devices and other networks (T-Mobile, Verizon, etc) and same 404 issue. I’ve asked a friend to check it which she is in the US and she gets 404 error. So this looks like a United States issue.

If I add “www” on these couple pages they work. I have no other issue with the hundreds of pages I have on my site with or without the “www”. Going through my analytics this started in November.

I’ve done a DNS flush, disabled DNS proxy to see if it would work, republished pages, register dns, and etc.

Not sure what else to do here.


what is the url?

Which does the canonical (“official”) use? With? Or Without ‘www’?

My canonical URLs don’t use ‘www’, so I have a redirect that takes it off.

If ‘www’ is your preferred URL, then a Page Rule should fix it:

Match: example.com/*
Setting: Forwarding URL (301) to https://www.example.com/$1


its happening to these 3 pages specifically

One thing I noticed today. I am seeing something change in the https://fanrankings.com/boxing/articles/top-10-amateur-boxers-2021-rankings/ url. Today so far I have 18 successful clicks from the US and only 2 404 errors. Hopefully this is a good sign. I can’t say the same for the other 2 urls

I setup the page rule without the “$1” by mistake and now when someone clicks on a page through google it goes straight to the homepage.

I fixed it but its still happening. I’m thinking its gonna take a couple minutes to fix update. I hope so cause I’m freaking out a bit

It’s working!!! Thank you!

Is their a reason why a couple pages are 404’ing when it is without the www?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.