404 Error After Activating Proxy

Hi,
I am getting a 404 error and a blank page after activating Cloudflare on green-steam.com
It looks like a SSL issue, it’s just I’ve never got this before for all the other domains proxied.

I have contacted my hosting at KnownHost. The domain works, no issues at all, redirects and all with Cloudflare disabled. I have purchased the APO for WordPress for a speed boost, that is why I am using Cloudflare. Additionally, I use WP Rocket, but that should not influence things in any way.

This is the response from my hosting:

"The full response header from CloudFlare indicates a cache hit:
===
[ryan]@[knownhost] [~]
-$ curl -ILks green-steam.com
HTTP/1.1 404 Not Found
Date: Sun, 08 Aug 2021 20:30:10 GMT
Content-Length: 0
Connection: keep-alive
CF-Ray: 67bb80416ddefa03-ATL
Age: 21
Vary: Accept-Encoding
CF-Cache-Status: HIT
Request-Context: appId=cid-v1:f867b18b-e971-419c-93bf-17dbf20b1181
X-Builder-Tracking-Id: 189e8c05d6cd497c96a15391223d8e1f
X-worker-origin: skip-rule
X-worker-version: 1.0.0
Server: cloudflare
===

So while the site is cached, it’s caching a seemingly empty or non-existing page. When looking at the domain’s request logs, the only 404’s I’m seeing logged are for the site’s favicon.ico file, but this was for direct connections (ie, not with the proxy enabled).

> This is the setting I was referring to:
This may be the issue. While your site is using CloudFlare, I’m not seeing any requests from us reaching your server at all. This may be due to CloudFlare’s origin cert not being installed on the server, and therefore it’s not able to complete a secure connection, and is just failing with the 404. You may want to try reducing this to Flexible instead of Full Strict, and see if it has better results."

This looks like a SSL setup issue, that I do not have on my other very similar domains.

Anyway, I would greatly appreciate any advice on how to deal with this. Right now, I have paused Cloudflare on the site as I do not want the issue to affect it longterm.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.