403 forbiden

I am trying to get my feed with this code.

wget -O - Sunday World

and I’m getting 403 forbidden error.

Which setting is causing this on cloudflare?

Hi @user4786,

Take a look at the response body:

[{redacted} ~]$ curl https://sundayworld.co.za/feed/
error code: 1020

Error Code 1020 indicates a firewall rule violation. I tried changing my user agent to look like a browser - that worked.

[{redacted} ~]$ curl -I -H "User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:93.0) Gecko/20100101 Firefox/93.0" https://sundayworld.co.za/feed/
HTTP/1.1 200 OK

I’m quite certain you have a firewall rule blocking automated user agents. This article should help you identify what rule is doing it:

Thanks a lot @albert there was a rule which was turned on and I turned it off and it worked.


No problem! You could optionally keep the rule turned on but add “and not URL path startswith /feed” - though if you’re looking to block bots, that’s not the best way to do it anyways. As I showed above, changing my user agent allowed me to bypass it pretty easily :slightly_smiling_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.