403 Forbidden (Help Please)

I can’t access my own site. I’m new to Cloudfare, and there seems to be a learning curve to this.
I looked on the “Community” page and have tried a couple of “fixes” already. I paused Cloudfare yesterday, but it’s still not letting me through. I’ve reverted the servers back to my host for now.
I’ve spent a lot of money on “learning” up to this point (for products & services I ended up replacing). Until I know what I’m doing I’m not interested in paying for more. It’s easier to just start from scratch.
So, if someone can point me in the direction of easy-to-follow instructions on how to use Cloudfare I’d appreciate it. There seems to be a lot to this. And I’m not cheap. I just don’t want to pay for something else I end up not being able to use, or obstructs my site.
Cloudfare seems to have a good reputation. It would be nice to become someone else who can attest to that. I’m just a tad frustrated at the moment.
(Help)…

Hi, please answer the following questions if you can.

  • What is your domain name?
  • What hosting provider are you using? (like GoDaddy, or Hostinger, DigitalOcean, etc…)
  • What hosting control panel are you using? (like cPanel, Plesk, or LAMP)
  • What CMS are you using for your website (if any)? (like WordPress)
  • What is your website about, is it a company profile, or ecommerce?
  • What have you tried with Cloudflare thus far that you had difficulty with?

I’m asking these questions to get a bit more context to help you. You don’t have to answer all the questions, just provide some more info to the community can better help you.

www.deveritasresources.com
1984 Hosting
cPanel
Wordpress
There’s nothing up there yet. (Just a blank slate). I don’t upload anything until the backend stuff is sorted.
I’m brand spankin’ new to Cloudfare. Just started… All I’ve done (so far) is the basics. Changed nameservers; added plugin. Cloudfare said everything was transferred well enough. Then I couldn’t access my site. I don’t have access to the webhost’s .htaccess file. I’ve emailed them. I’ll likely hear back tomorrow. But I’ve used other security/ CDNs in the past. I didn’t have the 403 problem with the reverse zones there. So I’m confused why Cloudfare would be different.
Is that enough to go on? Let me know. And if you have any tutorials I’m all eyes and ears. I learn on a need to know basis. And this is something I think I need to know. lol
Thanks!

That 403 error is coming directly from your origin server. Your naked domain, and www alike as it’s a CNAME pointing at the naked one, are resolving to 185.xxx.xxx.219

You don’t appear to be using Cloudflare’s nameservers:

$ whois deveritasresources.com
   Name Server: NS0.1984.IS
   Name Server: NS1.1984.IS
   Name Server: NS1.1984HOSTING.COM
   Name Server: NS2.1984.IS
   Name Server: NS2.1984HOSTING.COM
Name Server: ns0.1984.is
Name Server: ns1.1984hosting.com
Name Server: ns1.1984.is
Name Server: ns2.1984hosting.com
Name Server: ns2.1984.is

Correct. I reverted the servers back because I couldn’t access the site. However, that was only done a couple of hours ago. I paused Cloudfare last night, hoping it would fix the issue. It was one recommendation from the community. When that didn’t work I reverted the servers.
Should I revert it back to Cloudfare’s servers and address the issue then?
Recommendations? I’ll follow the steps to the letter.

I’d suggest that you resolve whatever issues you’re having with your origin server before anything. Once your site is correctly loading directly on the origin, go ahead with configuring Cloudflare.

2 Likes

Sounds good. I’ll close this thread for now, and wait until I hear from the host. Thank you.

Is your public_html does not contain any index.html or index.php file then it maybe the cause of this 403 Forbidden error.

Check what is your default folder, it’s usually “public_html”.
Check what if your folder contains a index.html or index.php folder, or something else index.*?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.