403 Error when I try to access Page Rules

I’m trying to access the Page Rules on one of my domains, but I keep getting the “403 | You don’t have permission to view this page.”

To the best of my knowledge, I should have access. I can’t find any info on how to fix this.

Sorry for the issues with that. Can you log out from your Cloudflare account, clear your browser cache, and log back in? If the problem persists let us know here.

Hi there, thanks for your reply.

I have tried what you advised - no change. I’ve also tried using a different browser and I’m still getting the same results.

1 Like

Is it the same account you are using here? Are you the superadmin of the account?

Yes, should be the same account. I suspect that I’m not super admin - I’ve been trying to contact an ex-colleague who setup the original account in regards to this. Sounds like this might be the problem. I wasn’t sure as the error screen seems more generic error

I was wondering that as well, can you share the name of a domain in the account?