39% Error rate for Error 525s

Hi all, I’m new here.
I’ve created a new site and I’m getting loads of Error 525 issues. I asked some friends to test the site and the error rate is 38.97% which is not cool.
I have followed the tutorials and guidance as well as I can, but I’m not all that technical on the web side of things. Any advice or suggestions would be appreciated.
The website is training.nickholt.co if you want to try it out.
Thanks

I can confirm I’m also seeing 525 error.

You said hat you have followed some of the guidance, are you referring to installing the origin ssl certificate on your hosting? And can you tell me what hosting control panel your using, cPanel or Plesk or something else?


t

Error 526 from another location. Certainly seems like an issue with your origin certificate.

Whilst its recommended to solve the issue and keep Full (Strict) mode, as a temporary measure you can change the setting in your zone >> SSL/TLS >> Overview >> Flexible mode.

Hi Thanks for looking at this. I have an SSL certificate on Cloudflare so i’m confused by this.

I bought the domain from GoDaddy but its not hosted by them, its an integrated package called SWYK Tools so I don’t have access to the cPanel or equivalent. Do I need to get ANOTHER SSL on wherever it is being hosted?

Also when I change the setting to Flexible, I can’t access the page at all, its says “To many redirects”, so i’ve changed it back to Full.
I can access the webpage and so can some others, but too many people are getting that error 525 handshake thing

That loop is caused by your hosting trying to redirect HTTP to HTTPS. Not to worry, keep it on Full and proceed to install the SSL certificate to your cPanel (or equivalent).

Yes.

Cloudflare provides SSL between your end-users and the Cloudflare point, then you need another SSL between Cloudflare and the web hosting.

Cloudflare will allow you to use a self-signed SSL certificate (usually pre-installed by your hosting provider) when configured to the “Full” mode. When configured to the “Full (strict)” mode it requires a trusted SSL certificate.

You can generate a 15 year SSL certificate through Cloudflare, and then install it to your cPanel (or equivalent).

ok. Thank you so much for your help.

I’m still seeing error 525 and error 526 sometimes, did you add the SSL certificate to your origin?

No. I don’t know how. I have someone I can ask to show me, but not until Friday.

It may not even be the issue, but a reasonable first step to ensure we can eliminate that as the problem.

Hi @nickholt9

Your issue was related to having the DNS record pointing to 2 different destinations which when inbound traffic hits the Cloudflare servers, Cloudflare would randomly pick one of the records to use for connecting to your origin. Since only 1 of the records was valid and the other wasn’t, this would explain why the SSL error 525 and error 526 was happening intermittently for about half the requests.

Thank you again so much for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.