35 (ssl_connect_error)

I am getting this error when adding my website URL to Facebook Share Debugger.
Here is my website link https://businessmindtd.com/
See the screenshot from FB debugger https://prnt.sc/ryjo6k
The OG properties are also added to the header but it doesn’t see it.
Can you help to fix it?

1 Like

Lower your minimum TLS version to 1.2.

1 Like

How do I do it with CloudFlare?

Under the TLS settings.

1 Like

Hey Sandro!
Thanks a lot you are a life saver :smile:

You the real MVP. This took away almost 24 hrs from me. When will TLS1.3 be compatible though?

You’d need to ask the Faceybook.

This topic was automatically closed after 30 days. New replies are no longer allowed.