301 Redirect going to wrong URL

We created the cloudflare account and set up a 301 static redirect for example01 dot com on 2/7/2024. The domain is registered at GoDaddy where we updated the nameservers to the directed cloudflare nameservers. Upon doing this, the redirect we set up appeared to be working for 8 days and pointed to the new URL correctly. Yesterday, 2/14/2024, upon checking the redirect, we found that it is instead forwarding to a URL which seems to be a temporary domain in place at Volusion which is the previous website provider. We do not understand how the example01 domain is redirecting to the old provider site URL with the settings we have in place at cloudflare correctly redirecting to the new URL. The same day we implemented the account and 301 redirect for example01, we also created an account and a static 301 redirect for example02 dot com that points to the same new URL domain as example01 is supposed to be pointing to and the example02 redirect is still working properly. Does anyone have any suggestions to get this redirect working again?

What is the domain? Can you show a screenshot of your redirect rule?

example02 is in place of the actual domain but was not saved. The actual domain is still in place on the redirect.

Without knowing the domain you are redirecting from, I can’t check what is actually happening.

1 Like

mdbarber dot com

The redirect to Volusion is happening on your origin server…
https://cf.sjr.org.uk/tools/check?cf698885abdc4754adb68ab0f0eb37cc#connection-server

We need to work out why the Cloudflare redirect isn’t happening first.

Just to check…

  • the page rule is under the Cloudflare zone for mdbarber.com?
  • what is the domain you are trying to redirect to (ending /pages/landing-page)
1 Like

Yes, the redirect is under the mdbarber zone
The domain we are trying to redirect to is wbbarber dot com/pages/md-barber-supply

The nameservers are pointed to cloudflare, so the DNS lookup should be happening at cloudflare, not Volusion (where the servertrust domain is showing)

Can you check…

  1. The page rule you have created is enabled on this page…
    https://dash.cloudflare.com/?to=/:account/:zone/rules

  2. The nameservers at the bottom of your DNS page are bowen and melody
    https://dash.cloudflare.com/?to=/:account/:zone/dns

2 Likes
  1. It is not a page rule; it is a redirect rule. Therefore, it’s on the redirect rules page under mdbarber.
  2. The nameservers are set to bowen and melody. (Which can be checked on doing a DNS search.)

Yes, my mistake. Still, can you check the rule is actually enabled here…
https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

Yes, they are what is set at the registrar. I wanted to check that those are correct and match the nameservers shown on the bottom of the DNS page here…
https://dash.cloudflare.com/?to=/:account/:zone/dns

1 Like

Just checked, www.mdbarber.com does redirect correctly as set…
https://cf.sjr.org.uk/tools/check?1eee1124e3e94112a415814124fee8a1#connection-server

What do you have as a DNS entry for mdbarber.com?

Yes, redirect rule is enabled.
Yes, the NS match the ones listed at the bottom of the DNS page.
The www CNAME record is pointed to mdbarber dot com. The DNS A records for mdbarber dot com in the DNS records start with 172. and 162. When resolving the DNS for both the mdbarber and the www mdbarber, they resolve the same. Considering that the www points to the main domain, and is working, then the main domain SHOULD be working, but isn’t.

(Sorry for all the questions, but it is a bit odd so I’m trying to find any reason why the redirect rule isn’t triggering for the apex domain, but is for www).

I know how they resolve, I’m looking for what have you set as the record in your Cloudflare DNS here…
https://dash.cloudflare.com/?to=/:account/:zone/dns
Can you show a screenshot of that page?

Assuming this is the page you mean as when I click on the link it takes me to the home screen where I have to select which user account I want to look at.

Can you delete both of the A records, and replace with a single proxied A record for @ pointing to 192.0.2.1.

That’s fixed it. The IP addresses were Cloudflare ones, seems the page rule would not override those as it would for other IP addresses (or the CNAME for www).

curl -I https://mdbarber.com
HTTP/2 301
date: Sat, 17 Feb 2024 00:33:33 GMT
location: https://wbbarber.com/pages/md-barber-supply
cache-control: max-age=3600
expires: Sat, 17 Feb 2024 01:33:33 GMT
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=JugoKBczICAECwIiwBj50N%2FTjfAkY%2BwoCbnDdzMy%2BnMfdU6FTOEpB4vYLqQE3hhj3zbm2ranEMwuMl6qzGsrECpXbkusH%2Ft6tJbhubT50hqZz1%2BDk%2B4PWg7viIyII0Q%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 8569f08aee98dcd3-LHR
1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.