1and1 es SSL make it run with worddpress


#1

Hi,
on 1und1 .de I made it run for a client site. www.pro-solvent.de
But on 1nd1. es I cannot make wordpress and SSL work.
Example: www.europremiumlotto.com

What is the big issue with 1and1.es?

Andre


#2

SSL works just the green lock is missing because your page serves mixed content. Some pictures are loaded via HTTP instead of HTTPS.

Ensure that all traffic is redirected to https. Either with cloudflare‘s page rules or directly on your server.

Details here:

https://www.webpagetest.org/result/180526_EG_987cce3800ac18033c97ebc9ed70a97e/1/details/#waterfall_view_step1


#3

As far as I could tell it is only for the three background-image CSS definitions with HTTP URLs on the main page.


#4

Sorry, but here nothing works. I first thought its because 1and1 always takes forever for dns changes to become valid. But look attached pic. Made from mobile freah browser


#5

I’m not able to replicate that with a mobile browser. Which phone/browser is that?

Does the DETAILS link give any more information?


#6

I am sorry to have bothered you, while I just didnt see that it was kind of running.
But now I will be able to have all others on 1and1 es also to get to run.
Thanks for helping so much, all the best.


#7

that was firefox on android phone


#8

As we are here in the topic of 1and1 .es as well, I wonder how to make the ftp work…
I cannot access the sites through ftp anymore, I forgot how I made this work with 1and1.
they use hostname setup for this, not IP based. so it can be like a home12345678.1and1-data.host

But the setup in cloudflare goes to ftp A- server record and then I can use orange or grey cloud. but nothing more.

Can you help with this?


#9

You can use the hostname as well, is simply has to point to the right IP address (= the server, not Cloudflare).


#10

ftp as A record should be fine. Don’t set it to :orange: Cloudflare will not proxy it.

Careful if you use :grey: records they expose your host. If you don’t have a dedicated IP use the hostname that was given to you by 1&1 an set a CNAME.

ftp CNAME homewhateveritis.1and1.bla


#11

ah I see. so I delete the a ftp 1.2.3.4 record
then I add a cname like you have said and leave the orange cloud active??

So far doesnt work


#12

Set it to :grey:

:wink:

And give it some time. It could take a while depending on the TTL that was set


#13

Ok,and the hostname I use in Filzilla then is ftp.mydomain.com right?

But 1and1 also requires sftp BTW, is that making any difference?


#14

no. You can use any protocol as long as CloudFlare is not active for this record.


#15

ok, lets see if its working.
I am always suspicious about things 1and1 creates.
;D


#16

Mee too. ^^

Though my ADSL is working fine for about 10 years now. Oh wait: it’s just built on DTAG stuff using a 1&1 PPPoE user . maybe therefore. :joy:


#17

Hehe, that is another topic as discounter for this stuff. But hosting they meanwhile give not a bad service, just their phillosophy is weird. mod_security always enabled and so and they block my website security from loggin, cause the log mentions the threat so and1 acts if this log WAS the threat. silly stuff.
and so.

But hey, it seems to have worked not fully.
Look please:

Status: Verbinde mit ftp.thisfuckingdomain.com
Antwort: fzSftp started, protocol_version=8
Befehl: open "[email protected]" 22
Befehl: Neuem Serverschlüssel vertrauen: Ja
Befehl: Pass: *********
Fehler: Authentifizierung fehlgeschlagen.
Fehler: Kritischer Fehler: Herstellen der Verbindung zum Server fehlgeschlagen

#18

Authentication failed.

Sure your credentials are correct? :thinking:


#19

Yes, sure they are. I haent changed it. only changed the hostname.
I believe 1and1 doesnt consider this ftp.mydomain.com to be not connected to the original credentials.

I can set a new ftp account up in the 1and1 hosting panel and try it


#20

Hahah, Mister. You were right. hahah. I created a new FTP account with same rights, and it worked. But I really did change NOTHING before only the host. Maybe it “forgets” the first setting… funny. now it works with new account.

Your setup is correct.: I just would recommend anybody to create a new account