19 days and I still can't update payment info

It’s been 19 days and I still can’t update billing information and I’m about to lose several domains. Here is the previous ticket. Can't update Payment information

Customer service stop responding 8 days ago. Can anyone help?

That ticket should be active. What’s the very last thing they said?

I’ve sent 4 emails since that are unanswered. This was the last message.

Christine Alejo (Cloudflare)

Oct 21, 2021, 10:51 PM PDT

Hello there,

Thank you for your response. Hope you are having a great day!

My sincere apologies for the inconvenience here.

Our Billing Engineering Team are finalising the fix for this issue. Please bear with us and rest assured that we will get back to you as soon as possible.

Thank you for using Cloudflare. Stay safe and healthy please.

Thank you very much

Best Regards,

Christine
Cloudflare Billing Support Specialist

Wow, that’s been a while. Unfortunately, it’s the weekend. But Billing gets in pretty early on Monday mornings and @Laurie usually checks for weekend activity when she gets in.

If it’s domain registrations, I have about a third of mine registered here, and the rest elsewhere. There’s not much of a cost difference, and other registrars offer more features. If you’re getting close to a week away from domain expirations, I recommend you transfer them away.

3 Likes

I switched most of my domains from a registrar that offered great 1st year prices but stick you after that…

Thanks for your feedback!

1 Like

Hi @tcarter,

Checking your ticket, I see that our team replied to you yesterday. Our engineering team is working on the fix for this issue. As a side note we have seen success when attempting to update your payment method via mobile as a workaround. You will be updated in the ticket as soon as our team has further information to share.

2 Likes

The reply I received yesterday was “We’ll check in with them tomorrow, and if the result is not positive, I’d likely agree with the response you got in the community.” Can you check with engineering team for an ETA on the fix?

I just tried it on mobile and received the same error message.

Thanks,
-Tony

Hi @tcarter,
Unfortunately, we are not going to be able to resolve this through your multiple posts here. This is being worked on by our engineering team at this time and as soon as there is an update it will be shared with you via the ticket.

2 Likes

This post was flagged by the community and is temporarily hidden.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.