172.67.133.7 Not responding to Oregon area Comcast connections

I’ve been fighting an intermittent issue where my sites proxied by Cloudflare will just decide to not load and will eventually time out for a few weeks now. Typically this happens for websocket connections to my different services within a panel. However it can happen to anything hosted by only what I can confirm to be free tier Cloudflare services. I would also assume now that this is why some other websites and content frequently don’t load as well though and require a refresh of the page.

What it seems to all boil down to that whenever Cloudflare resolves through 172.67.133.7 it does not respond to Oregon Comcast connections. I spent about a week trying to get in contact with anyone at Comcast who was qualified to read a traceroute. I was eventually able to get in touch with someone locally and they were able to confirm that on their end they were also unable to reach said IP address from within the network. Their superior however was convinced that the packets were leaving their network so there for there was nothing they could do about it. If need be, I can happily provide a contact number to Cloudflare staff to get in touch with them if need be.

Every other VPN, VPS and other connection I can get my hands on that is not a local Comcast connection is able to reach this IP address perfectly fine. The traceroute dies on 96.216.158.45 which is a Comcast IP. Pings time out and my domains generally resolve to 172.67.133.7 about a third of the time I try to resolve them.

I am also using 1.1.1.1 and 1.0.0.1 with forced redirection, but it also happens with google dns and the isp provided dns connected directly at the modem.

I really am not appreciative of having to post this much information publicly, after spending hours waiting for my account to activate before finding some random subtle clue that I have to earn badges to post here to get any support or contact anyone. Here’s the :black_flag: and a tag to @“something else” or whatever so this gets deleted afterwards.

2 Likes

I have a similar problem, randomly some Cloudflare ips stop responding to my ISP (In my case it’s Vodafone Portugal).
If I try to ping/traceroute to the ip number above or below the problem ip those work just fine.

I’ve tried to report to Cloudflare and they say it’s a vodafone problem, but when vodafone do their tests they say it’s a Cloudflare problem.

All I know is that it’s random, sometimes the problem disapears after a couple hours, sometimes it takes 12 hours for the problem to disappear and resolve itself.

unfortunately I’ve not been able to get real support from Cloudflare as I always get the “it’s not us problem, it’s them”.

for example currently I can’t reach 188.114.97.12 188.114.96.12 188.114.97.3 188.114.96.3 which are beeing routed to the Cloudflare LIS (Lisbon) colocation.

I assume different colocations will be affected with different ips having the same problem => no ping, no traceroute, no open ports 80 or 443 no nothing…

2 Likes

Yeah, that’s almost precisely my problem. .6 and .8 work perfectly fine. My issue however absolutely does not disappear, I have never been able to reach 172.67.133.7 as long as I’ve been aware of it and its a near 50/50 thing where all of my domains resolve to this IP.

Pinging 172.67.133.6 with 32 bytes of data:
Reply from 172.67.133.6: bytes=32 time=20ms TTL=56
Pinging 172.67.133.7 with 32 bytes of data:
Request timed out.
Pinging 172.67.133.8 with 32 bytes of data:
Reply from 172.67.133.8: bytes=32 time=24ms TTL=56

I’m assuming there has been some IPs that have been marked as abusive and put on a denylist somewhere, probably a long time ago. Cloudflare then acquired those ranges and I doubt anybody is going to personally manage spam filtering lists to check if the IPs are still potentially malicious. I still suspect it’s my own ISP doing something as dumb as filtering out traffic to Cloudflare addresses. But I’d really appreciate some sort of a response from Cloudflare before I start hassling my ISP.

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
29 packets transmitted, 0 received, 100% packet loss, time 28219ms

172.67.133.7 still does not respond despite 1.1.1.1 and 1.0.0.1, and other dns servers resolving to these ips. Today every one of my domains and subdomains resolved to this IP again, as it does every single day and has for over a month now.

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
1223 packets transmitted, 0 received, 100% packet loss, time 1231777ms

IP continues to be unreachable by Comcast connections.

Once again like every day when trying to use Cloudflare services, domains resolve to 172.67.133.7 which is and has continued to be completely unreachable.

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
74 packets transmitted, 0 received, 100% packet loss, time 73587ms

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
28 packets transmitted, 0 received, 100% packet loss, time 27212ms

Cloudflare continues to proxy many domains to an IP that my ISP is unable to reach.

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
443 packets transmitted, 0 received, 100% packet loss, time 445535ms

Issue still persists.

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
5 packets transmitted, 0 received, 100% packet loss, time 4037ms

Cloudflare’s IP still is unreachable by much of Oregon’s Comcast network.

Hey,

I’d advise you reach out to Comcast about this issue since it seems to be a specific point within their network from what I understand of your messages :slight_smile:

Already have done that. I was given a direct line to a network engineer that can be contacted by Cloudflare to work with them. They confirmed the issue and told me there’s nothing they can do because the “packets leave their network” and I just can’t see it because those hops in the traceroute don’t respond according to them.

I just got off the phone with them, Comcast themselves tried to contact the IP internally from multiple locations in Oregon as well as Denver, Colorado. The IP 172.67.133.7 does not respond and the connection is dropped when reaching Cloudflare.

So apparently this issue is much farther reaching than just Oregon but rather affects a very significant portion of Comcast’s network.

I am happy to privately provide traceroutes, IP addresses, phone numbers or even SSH access to something directly connected to my modem if need be. Anything to resolve this issue.

Do you have an example of a traceroute from when you are able to connect to that IP address?

When it’s working, find a site that resolves to the 172.67.133.7 address and try reach /cdn-cgi/trace on it and copy/paste the output here (removing your IP address if need be). As an example, https://cloudflare.com/cdn-cgi/trace - but that might not resolve to the IP address you’re having issues with.

Reaching 96.216.158.45 from pdx02 which is in Portland, Oregon seems to work fine at the moment.

{
  "hops": [
    {
      "packets_ttl": 1,
      "packets_sent": 5,
      "packets_lost": 0,
      "nodes": [
        {
          "asn": "",
          "ip": "172.68.173.1",
          "name": "_gateway",
          "packet_count": 5,
          "mean_rtt_ms": 0.833,
          "std_dev_rtt_ms": 0.17225126995177714,
          "min_rtt_ms": 0.75,
          "max_rtt_ms": 1.141
        }
      ]
    },
    {
      "packets_ttl": 2,
      "packets_sent": 5,
      "packets_lost": 0,
      "nodes": [
        {
          "asn": "",
          "ip": "69.252.236.133",
          "name": "ae-102-ar01.troutdale.or.bverton.comcast.net",
          "packet_count": 5,
          "mean_rtt_ms": 9.4238,
          "std_dev_rtt_ms": 0.0328892079564099,
          "min_rtt_ms": 9.374,
          "max_rtt_ms": 9.452
        }
      ]
    },
    {
      "packets_ttl": 3,
      "packets_sent": 5,
      "packets_lost": 0,
      "nodes": [
        {
          "asn": "",
          "ip": "96.216.158.45",
          "name": "96.216.158.45",
          "packet_count": 5,
          "mean_rtt_ms": 4.0464,
          "std_dev_rtt_ms": 0.018324846520503396,
          "min_rtt_ms": 4.015,
          "max_rtt_ms": 4.061
        }
      ]
    }
  ]
}
1 Like

I have never able to contact that IP from my connection as long as I’ve been aware of it. It’s one of 3 or 4 IPs which Cloudflare resolves my domains to which I’m sure plenty of other services also resolve to as well. Currently my browser has cached a valid IP for one of my subdomains while the other subdomain is unreachable and times out. When I ping that domain, it’s flips between 172.67.133.7 and 104.21.5.60 but there’s one more I believe that it sometimes also resolves to which works. The one that doesn’t function is the most common though.

fl=28f600
h=cp.exiledservers.net
ts=1651708231.104
visit_scheme=http
uag=Mozilla/5.0 (X11; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0
colo=SEA
http=http/1.1
loc=US
tls=off
sni=off
warp=off
gateway=off

I connected to a VPN shortly after it timed out hoping that it would use the cached DNS(172.67.133.7) from the browser, can’t say if it worked though. However, on my domains I am not seeing the SEA colo location at all after repeatedly opening/closing a private browser from my connection.

When it’s resolving to 104.21.5.60 it likely looks like this and loads just fine.

fl=447f55
h=cp.exiledservers.net
ts=1651707739.218
visit_scheme=http
uag=Mozilla/5.0 (X11; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0
colo=LAX
http=http/1.1
loc=US
tls=off
sni=off
warp=off
gateway=off

So it would seem that it’s the SEA location which I’m having problems with where the LAX is not experiencing issues?

SEA (Seattle, WA, US) seems to be able to reach 96.216.158.45

"hops": [
  {
    "packets_ttl": 1,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "108.162.244.1",
        "name": "108.162.244.1",
        "packet_count": 5,
        "mean_rtt_ms": 2.758,
        "std_dev_rtt_ms": 0.026296387584609407,
        "min_rtt_ms": 2.718,
        "max_rtt_ms": 2.781
      }
    ]
  },
  {
    "packets_ttl": 2,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "50.208.235.221",
        "name": "be-111-pe12.seattle.wa.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 1.0313999999999999,
        "std_dev_rtt_ms": 0.061186599840161136,
        "min_rtt_ms": 0.956,
        "max_rtt_ms": 1.114
      }
    ]
  },
  {
    "packets_ttl": 3,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.34.133",
        "name": "be-2212-cs02.seattle.wa.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 1.5622,
        "std_dev_rtt_ms": 0.12480464734936758,
        "min_rtt_ms": 1.406,
        "max_rtt_ms": 1.724
      }
    ]
  },
  {
    "packets_ttl": 4,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "68.86.93.54",
        "name": "68.86.93.54",
        "packet_count": 5,
        "mean_rtt_ms": 4.0886000000000005,
        "std_dev_rtt_ms": 0.04150662597706533,
        "min_rtt_ms": 4.025,
        "max_rtt_ms": 4.131
      }
    ]
  },
  {
    "packets_ttl": 5,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.216.158.45",
        "name": "96.216.158.45",
        "packet_count": 5,
        "mean_rtt_ms": 6.9584,
        "std_dev_rtt_ms": 0.010807404868885066,
        "min_rtt_ms": 6.941,
        "max_rtt_ms": 6.97
      }
    ]
  }
]

LAX (Los Angeles, CA, US) however always seems to end at 96.216.60.218 and I don’t get any responses or hops that say 96.216.158.45.

 "hops": [
   {
     "packets_ttl": 1,
     "packets_sent": 5,
     "packets_lost": 5,
     "nodes": [
       {
         "asn": "",
         "ip": "",
         "name": "NO RESPONSE",
         "packet_count": 0,
         "mean_rtt_ms": 0,
         "std_dev_rtt_ms": 0,
         "min_rtt_ms": 0,
         "max_rtt_ms": 0
       }
     ]
   },
   {
     "packets_ttl": 2,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "172.70.208.3",
         "name": "172.70.208.3",
         "packet_count": 5,
         "mean_rtt_ms": 9.427,
         "std_dev_rtt_ms": 0.12881964135953822,
         "min_rtt_ms": 9.305,
         "max_rtt_ms": 9.589
       }
     ]
   },
   {
     "packets_ttl": 3,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "50.242.151.225",
         "name": "be-108-pe11.600wseventh.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 1.0657999999999999,
         "std_dev_rtt_ms": 0.036724651121556,
         "min_rtt_ms": 1.001,
         "max_rtt_ms": 1.09
       }
     ]
   },
   {
     "packets_ttl": 4,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.33.53",
         "name": "be-3211-cs02.losangeles.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 1.3972000000000002,
         "std_dev_rtt_ms": 0.3428894865696526,
         "min_rtt_ms": 1.203,
         "max_rtt_ms": 2.008
       }
     ]
   },
   {
     "packets_ttl": 5,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.45.170",
         "name": "be-1211-cr11.losangeles.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 0.8639999999999999,
         "std_dev_rtt_ms": 0.1087726987805304,
         "min_rtt_ms": 0.79,
         "max_rtt_ms": 1.054
       }
     ]
   },
   {
     "packets_ttl": 6,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.38.94",
         "name": "be-302-cr11.9greatoaks.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 7.880800000000001,
         "std_dev_rtt_ms": 0.11854197568793932,
         "min_rtt_ms": 7.749,
         "max_rtt_ms": 8.039
       }
     ]
   },
   {
     "packets_ttl": 7,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "68.86.166.141",
         "name": "be-1211-cs02.9greatoaks.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 8.692200000000001,
         "std_dev_rtt_ms": 0.047850809815508676,
         "min_rtt_ms": 8.627,
         "max_rtt_ms": 8.749
       }
     ]
   },
   {
     "packets_ttl": 8,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "68.86.166.146",
         "name": "be-1212-cr12.9greatoaks.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 8.1408,
         "std_dev_rtt_ms": 0.10719001819199438,
         "min_rtt_ms": 8.042,
         "max_rtt_ms": 8.297
       }
     ]
   },
   {
     "packets_ttl": 9,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.37.181",
         "name": "be-304-cr12.sunnyvale.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 9.0252,
         "std_dev_rtt_ms": 0.21290185532305694,
         "min_rtt_ms": 8.743,
         "max_rtt_ms": 9.235
       }
     ]
   },
   {
     "packets_ttl": 10,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.46.29",
         "name": "be-1312-cs03.sunnyvale.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 9.147200000000002,
         "std_dev_rtt_ms": 0.3138418391483201,
         "min_rtt_ms": 8.792,
         "max_rtt_ms": 9.484
       }
     ]
   },
   {
     "packets_ttl": 11,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.46.34",
         "name": "be-1313-cr13.sunnyvale.ca.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 8.8704,
         "std_dev_rtt_ms": 0.14310765178703735,
         "min_rtt_ms": 8.691,
         "max_rtt_ms": 9.083
       }
     ]
   },
   {
     "packets_ttl": 12,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.36.126",
         "name": "be-302-cr11.portland.or.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 22.5582,
         "std_dev_rtt_ms": 0.11718020310615575,
         "min_rtt_ms": 22.471,
         "max_rtt_ms": 22.761
       }
     ]
   },
   {
     "packets_ttl": 13,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.110.46.209",
         "name": "be-1111-cs01.portland.or.ibone.comcast.net",
         "packet_count": 5,
         "mean_rtt_ms": 22.108200000000004,
         "std_dev_rtt_ms": 0.1284978599043588,
         "min_rtt_ms": 21.967,
         "max_rtt_ms": 22.263
       }
     ]
   },
   {
     "packets_ttl": 14,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "68.86.94.194",
         "name": "68.86.94.194",
         "packet_count": 5,
         "mean_rtt_ms": 23.9958,
         "std_dev_rtt_ms": 2.5895953737987716,
         "min_rtt_ms": 22.776,
         "max_rtt_ms": 28.627
       }
     ]
   },
   {
     "packets_ttl": 15,
     "packets_sent": 5,
     "packets_lost": 0,
     "nodes": [
       {
         "asn": "",
         "ip": "96.216.60.218",
         "name": "96.216.60.218",
         "packet_count": 5,
         "mean_rtt_ms": 28.153399999999998,
         "std_dev_rtt_ms": 0.05711654751470934,
         "min_rtt_ms": 28.092,
         "max_rtt_ms": 28.213
       }
     ]
   }
 ]

However, I wouldn’t consider the traceroute outputs I have to be anything more than a hint as to what the issue might be for Comcast/Cloudflare since without knowing how exactly it’s all routing between yourself, Comcast and the IP in question I’m just grasping at straws.

1 Like

When I trace out to 104.21.5.60 it goes through 96.216.158.45 as well but actually reaches it’s destination. Most successful connections seem to go through 96.216.158.45 and 96.216.158.17

5  96.216.158.45 (96.216.158.45)  12.432 ms  12.497 ms  17.456 ms
6  96.216.158.17 (96.216.158.17)  21.376 ms  20.347 ms  19.214 ms

The other IPs that work have also finally showed up, 172.64.131.38 and 172.64.130.38 these seem to return SJC.

fl=464f36
h=cp.exiledservers.net
ts=1651712018.248
visit_scheme=http
uag=Mozilla/5.0 (X11; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0
colo=SJC
http=http/1.1
loc=US
tls=off
sni=off
warp=off
gateway=off

Trying to ping some one of these IPs you provided though has produced some very interesting results.

ping 108.162.244.1
PING 108.162.244.1 (108.162.244.1) 56(84) bytes of data.
From 50.208.235.222 icmp_seq=1 Packet filtered
From 50.208.235.222 icmp_seq=2 Packet filtered
From 50.208.235.222 icmp_seq=3 Packet filtered

50.208.235.222 returns as “Comcast Business”, as does .221. Where 108.162.244.1 is very much a Cloudflare IP.

PING 172.70.208.3 (172.70.208.3) 56(84) bytes of data.
64 bytes from 172.70.208.3: icmp_seq=1 ttl=48 time=42.4 ms

The network engineer is supposed to call sometime tomorrow. The person that I have been in contact with has had to relay some information from his superior. It’s entirely possible there’s been a breakdown in communication at some point over there in what the problem is.

The person that I have been talking to seems to have a fairly good grasp on what the is problem though so it’s really hard to say. I’ll have to see what their opinion is hopefully tomorrow on 108.162.244.1.

Thank you very much, you have been by far the most helpful with this problem so far in the last month I’ve been seeking help with this. Maybe with this information things will finally be able to move forward so that this issue may be solved!

This is from sjc05 (San Jose, CA, US) to 96.216.158.45

"hops": [
  {
    "packets_ttl": 1,
    "packets_sent": 5,
    "packets_lost": 5,
    "nodes": [
      {
        "asn": "",
        "ip": "",
        "name": "NO RESPONSE",
        "packet_count": 0,
        "mean_rtt_ms": 0,
        "std_dev_rtt_ms": 0,
        "min_rtt_ms": 0,
        "max_rtt_ms": 0
      }
    ]
  },
  {
    "packets_ttl": 2,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "162.158.164.3",
        "name": "162.158.164.3",
        "packet_count": 5,
        "mean_rtt_ms": 1.7137999999999998,
        "std_dev_rtt_ms": 0.21049513058500904,
        "min_rtt_ms": 1.434,
        "max_rtt_ms": 1.932
      }
    ]
  },
  {
    "packets_ttl": 3,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "50.242.151.237",
        "name": "be-123-pe11.9greatoaks.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 4.151800000000001,
        "std_dev_rtt_ms": 0.020241047403728816,
        "min_rtt_ms": 4.121,
        "max_rtt_ms": 4.174
      }
    ]
  },
  {
    "packets_ttl": 4,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.32.241",
        "name": "be-2111-cs01.9greatoaks.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 1.5728000000000002,
        "std_dev_rtt_ms": 0.08386715686131252,
        "min_rtt_ms": 1.464,
        "max_rtt_ms": 1.657
      }
    ]
  },
  {
    "packets_ttl": 5,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "68.86.166.134",
        "name": "be-1112-cr12.9greatoaks.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 1.3076,
        "std_dev_rtt_ms": 0.046468268743304855,
        "min_rtt_ms": 1.238,
        "max_rtt_ms": 1.354
      }
    ]
  },
  {
    "packets_ttl": 6,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.37.173",
        "name": "be-302-cr12.sunnyvale.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 2.0392,
        "std_dev_rtt_ms": 0.3591485764972485,
        "min_rtt_ms": 1.621,
        "max_rtt_ms": 2.352
      }
    ]
  },
  {
    "packets_ttl": 7,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.46.41",
        "name": "be-1412-cs04.sunnyvale.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 1.5988,
        "std_dev_rtt_ms": 0.1168576056574838,
        "min_rtt_ms": 1.466,
        "max_rtt_ms": 1.7
      }
    ]
  },
  {
    "packets_ttl": 8,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.46.46",
        "name": "be-1413-cr13.sunnyvale.ca.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 2.1228,
        "std_dev_rtt_ms": 0.25010037984777234,
        "min_rtt_ms": 1.937,
        "max_rtt_ms": 2.561
      }
    ]
  },
  {
    "packets_ttl": 9,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.36.126",
        "name": "be-302-cr11.portland.or.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 15.665200000000002,
        "std_dev_rtt_ms": 0.07437539915859227,
        "min_rtt_ms": 15.582,
        "max_rtt_ms": 15.748
      }
    ]
  },
  {
    "packets_ttl": 10,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.110.46.225",
        "name": "be-1211-cs02.portland.or.ibone.comcast.net",
        "packet_count": 5,
        "mean_rtt_ms": 15.445400000000001,
        "std_dev_rtt_ms": 0.050450966294016214,
        "min_rtt_ms": 15.393,
        "max_rtt_ms": 15.527
      }
    ]
  },
  {
    "packets_ttl": 11,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "68.86.94.198",
        "name": "68.86.94.198",
        "packet_count": 5,
        "mean_rtt_ms": 19.34,
        "std_dev_rtt_ms": 1.2998269115539962,
        "min_rtt_ms": 17.017,
        "max_rtt_ms": 19.973
      }
    ]
  },
  {
    "packets_ttl": 12,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.216.60.218",
        "name": "96.216.60.218",
        "packet_count": 5,
        "mean_rtt_ms": 21.160999999999998,
        "std_dev_rtt_ms": 0.024010414407085505,
        "min_rtt_ms": 21.131,
        "max_rtt_ms": 21.185
      }
    ]
  },
  {
    "packets_ttl": 13,
    "packets_sent": 5,
    "packets_lost": 0,
    "nodes": [
      {
        "asn": "",
        "ip": "96.216.158.45",
        "name": "96.216.158.45",
        "packet_count": 5,
        "mean_rtt_ms": 21.1788,
        "std_dev_rtt_ms": 0.02499399927982729,
        "min_rtt_ms": 21.15,
        "max_rtt_ms": 21.215
      }
    ]
  }
]

I suspect Comcast can make more sense of them then I can, or provide other IPs to try and reach.

For context, these traceroutes are ran from the colos themselves.

If I ping it, mine gets a reply from a different IP address too - it might just be something upstream that isn’t a fan of ICMP & doesn’t allow it.

Unfortunate, yeah I’m getting either the Packet filtered response or a timeout from a few other connections that aren’t Comcast so it very likely doesn’t mean anything.

I was kind of excited this this might have actually pointed towards the actual problem, well at least we’ve likely narrowed it down to SEA.

Talked to Comcast last week, they found this reproducible from at least 5 different locations within their network including something from CenturyLink on the west coast. They reached out to Cloudflare and they received zero cooperation with this issue and were told by Cloudflare “very politely, to stop bothering them with this issue”…

Their only solution was to “not use Cloudflare”. Ha, jokes on me because there are absolutely no other choices which it comes to either my choice of ISP or using Cloudflare! I don’t control domains I don’t have access to!

ping 172.67.133.7
PING 172.67.133.7 (172.67.133.7) 56(84) bytes of data.
^C
— 172.67.133.7 ping statistics —
3 packets transmitted, 0 received, 100% packet loss, time 2009ms

Is there any way I can turn off SEA? Today I can’t even visit my domains because they just won’t load because of 172.67.133.7. Shoving my entire connection into a VPN seems like an absolutely ludicrous bandaid workaround. Something that is absolutely not a solution but it’s approaching to be on the table at this point. Then I’ll be IP banned from different online retailers and a whole slew of different services that filter non-residential IPs.

Is there something I can do to make this IP failover within Cloudflare? Like if I drop any packets heading to it at my router and make it timeout faster will that potentially cause the DNS to resolve differently? More hacky solutions are absolutely on the table, clearly this will never be resolved at this point.