1102 'Worker exceeded resource limits' but app not using worker

It seems like this is impacting some people intermittently at the moment. Are you also using Zaraz?

I’m using Zaraz and keep getting the same error.

Cloudflare Ray ID: 75e66606af6fdb76

Hello,
I have the same issue. Sporadic 1102 errors reported by users. We use Zaraz and no workers. I’ve disabled zaraz…is there a fix available???

Thanks for the additional reports. The team have been made aware of the issue, and it’s been escalated. I do apologise for the issues, and would recommend you disable Zaraz temporarily in the meantime if it’s causing you consistent problems - disabling Zaraz should prevent the issue from occurring moving forward.

For anyone reporting problems, if you could provide an account ID, zone ID, ray ID, and the colo(s) you’re hitting as per the output from example.com/cdn-cgi/trace that would be really helpful to add to the report.

1 Like

I have been experiencing the same issue starting a few days ago (4 days ?).

Account ID : 6ef50442779d29497b7a4bec4bb0929a
Zone ID : b03bb6cb0dacc04970845d73c9840436
Ray ID : 75f46a68cb665c26 @ 2022-10-24 17:26:12

I was using LinkedIn Insight with zaraz. Disabled everything to avoid further errors.
Note that my page is a static angular with webpack/babel, which means tons of JS code to parse for zaraz maybe ? just a random thought

fl=19f214
h=REDACTED
ip=REDACTED
ts=1666633476.174
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36
colo=CDG
sliver=none
http=http/2
loc=FR
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off
kex=X25519

Greetings,

Sorry to hear you are having trouble, and thanks for your patience on this matter.
This has been identified as an issue with Workers runtime and the Workers team is currently investigating. We will update here with developments as they are made available to our support team.
Thank you.

4 Likes

Same problem here. According to this topic Cloudflare was aware of the problem OVER 1 WEEK AGO and the issue is STILL NOT FIXED

This is the SECOND TIME that Zaraz throws errors on our websites. Last time was just last September Zaraz Debugger keep popping up intermittently for visitors - #6 by yoav_zaraz
This is a very unstable product, terrible user experience

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

I do not have any workers set up on my Cloudflare account. I don’t remember setting it up at all, but I do have a subdomain. But despite this, over the past few days, some pages on my website have taken a few seconds longer than usual (less than a second) to load and then I get shown a 1102 ’ Worker exceeded resource limits’ error. Any ideas what could be causing this?

Are you using Zaraz? There is currently an issue that’s being investigated impacting some users.

I would recommend disabling Zaraz for now to avoid these intermittent issues.

Ah, yes, I am using Zaraz. Is there somewhere I can find updates on this issue so I know when I can turn it back on or if any temporary solutions are announced?

Not at this time unfortunately outside of following this thread:

I will do my best to relay any further information that I hear.

A fix has been rolled out for this issue. Can those experiencing any problems please be sure to report back if you see it occurring again?

We’ve had some customers report 1102 errors on our site today.

No workers.

Zaraz enabled (and frankly one of the key features that we chose Cloudflare for).

The frustrating part is that they’re reportedly happening on a very very basic php mailto script.

Our team is working hard to resolve this issue. It’s currently top priority for us. Apologizes for the inconvenience. We will update on the Discord channel once it’s resolved.

2 Likes

Wanted to report I’m seeing the same issue (as recently as today) on a site not using working but am using Zaraz.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Hi. My website is experiencing the same issue. We have a DNS CNAME to the Pages url and as you can see the Pages url gives you the json all the time but the second URL gives you Error 1102 on and off. Any suggestions what I can do to get around this issue?

Worker exceeded resource limits

https://stockideasweb.pages.dev/stocks/aapl/q-data.json

https://www.stockideashq.com/stocks/aapl/q-data.json

p.s: one ray id is: Ray ID: 76ff373897fa544f
And yes I was also using Zaraz before but have it disabled and remove now but problem still persists.