1016 error with no CNAME record and proper A record after using domain for CF Pages

Hi! I’m getting a 1016 error when I enable the Cloudflare proxy for my tyoma.io domain, and I believe that this error shouldn’t be there.

It started showing up after I used this domain for Cloudflare Pages, and then rolled back to using it for my own server.
So, here is a timeline:

  1. tyoma.io domain was pointing to the IP address of my server via A record, everything was ok
  2. I created a Cloudflare Pages project, removed the A record from the domain, and set up the CNAME the way Cloudflare Pages suggested
  3. I removed the domain from the Pages project, removed the CNAME record from the domain, removed the Pages project, and added an A record pointing to my server
  4. Since this moment, whenever I enable Cloudflare proxy for this domain, I’m getting the 1016 error

Here are the reasons why I think it’s not my fault:

  1. The website works when I’m not using the Cloudflare proxy, and the domain successfully resolves to the IP I specify both locally at my PC, and via the dnschecker.org
  2. It works regardless of the server I choose the domain to point to (I have two running, one at 82.148. 28.73, and the second one at 209.250. 253.34, both work and resolve perfectly). So without the Cloudflare Proxy it works on both IPs, and with it - it doesn’t work on any of them.
  3. CNAME record for Pages for the tyoma. io domain has been deleted by me yesterday, and it doesn’t show up on dnschecker.org
  4. It stopped working immediately after I tried using Pages, without any substantial difference between the DNS record before I tried using Pages and the DNS record after I disabled Pages, and it didn’t start working yet, so it’s probably not the case of me being a bit impatient

Here are my current DNS settings:

Hi. I had the same error. I fixed it creating again the Cloudflare page and adding the same custom domain and then delete it again.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.