1016 error only when using HTTP proxy


#1

Just recently, my HubSpot site started getting an Origin DNS error 1016 when I use http proxy. Everything works fine when I have the orange cloud off, but whenever I turn the orange cloud on for the cname, I get the 1016 error.


#2

It looks like you already found a solution on another thread. If Hubspot is like other Cloudflare-fronted services, you can’t :orange: it. In fact, some similar services won’t even :orange: or :grey: because of this. They won’t even give you the option.

What I suggest is you :grey: it, then check the HTTP headers to see if it still has Cloudflare headers in there. If so, then leave it :grey: and Hubspot is handling the Cloudflare work for you.


#3

OK, thanks. Is there any way to redirect to the www domain without it turned on?


#4

Without :orange:, not from here. It’d be up to where you’re hosted to find a way.