10021 Can't set compatibility date in the future: 2024-02-03

I’m getting this error when trying to create a Supabase integration.

I suspect this is just a timezone issue where the request from my browser should use UTC rather than local time. I’m in Australia at 7.30am with offset +10 so the date in the request is the 3rd of Feb rather than the 2nd of Feb which would be the current server time. I suspect the issue may resolve itself if I try again in a few hours…

Yeah, this is a known issue with some workers templates that the team is aware of. You can edit the request and change the date yourself, or wait the timezone to line up.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.