10012 Forbidden when trying to set a webhook url


#1

Is anyone able to set a web hook url for their encoding updates?

I tried follow the steps on https://developers.cloudflare.com/stream/webhooks/, but I always get a forbidden message when I try.

I know that neither my account id nor auth key are wrong because I tried hitting https://api.cloudflare.com/client/v4/accounts/{account_id}/media with the same parameters and I get the proper results.


#2

I have the same issue, I can’t add or list webhooks.


#3

bumping this with the same issue


#4

Same issue here…


#5

hi @lee8, I see your ticket, if you receive an auto reply, can you respond to it with any additional details you have based on the reply? I don’t see other tickets with that issue but if anyone is affected, please contact support and let us know on this thread. Sorry for the issue you’re facing.


#6

Hi @cloonan - I’ve submitted a reply with additional details. My initial submission had the wrong API call (I was just trying random things once I got the error).

I’ve since posted a couple of updates with the correct API call (which results in the same 10012 Forbidden error) as well as some other random tests I’ve performed.


#7

I submitted a ticket and they replied after they “made some internal configuration changes” and now the webhook API endpoints work flawlessly. Thanks for the quick help, Cloudflare!


#8

I think I am also facing this issue. Did you get any proper solution? kodi


#9

@eleorlova9 see my previous reply. I ended up submitting a support ticket and they resolved the issue same day.