1 subdomain of 3 that I have does not work

Hello I need help I have configured 3 subdomains in my account and when I configure 1 more I have problems since I get a 404.html error. I have reviewed everything and I do not know why I get this in this subdomain.


I suggest that you go to the DNS page here and edit the record for that subdomain and set it to :grey: DNS Only and then wait five minutes to take effect. Then fix your site so it loads correctly with HTTPS before setting DNS back to :orange: Proxied.

Hi @xavier.paredes
An HTTP 404 error is a client side error that means that the origin web server couldn’t find a requested file. Cloudflare does not generate 404 errors, so this would indicate something is not configured correctly at your hosting provider. It’s possible that a document root with your origin is pointed to the wrong host name or different working directory.

You should be able to find these errors 404 in the access logs of your origin web server.

The best next steps would be to work with your hosting provider to identify what potential misconfiguration could be in place that would cause the origin to look for a file where it doesn’t exist.

1 Like

It didn’t work for me

It was solved, the problem was that I had the SSL certificate active in full mode, this prevented my subdomains from working. when I put it in flexible the SSL there my subdomains worked correctly.
Thanks for the help.

1 Like

That means you didn’t do this:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.