1 error sitemap when using cloudflare

Hi. Has anyone here encountered this error and has a solution. I followed the instructions I found but couldn’t fix it either. See: s — ImgBB
da — ImgBB

My website: https://fry-electronics.com/ and https://interreviewed.com/

I can only confirm, at first time when I enter for example if using Yoast SEO plugin for WordPress, the URL to the sitemap into the Google Search Console, it always gives me an error or like error while fetching your sitemap while it actually can be accessed - but maybe it wasn’t generated before, so server would have few seconds longer to generate all of them, meaning the GSC would I do not which error or timeout get and show it as “unaccessible” in the dashboard.

It get’s normally after an hour or next day I see it indexed already.

I can access the sitemap via URL https://fry-electronics.com/sitemap_index.xml.

Therefore, when validation your XML sitemap, looks fine, but I think you are missing out the below on the starting <sitemapindex> tag as it should be:

<sitemapindex xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/siteindex.xsd" xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">

Could be I am wrong about this one, as the inner sitemaps like https://fry-electronics.com/post-sitemap1.xml have got them good.

I am using Rankmath Seo and cloudflare. I tried disabling cloudflare remove .htaccess tag, update again and resubmit sitemap it works.

But after updating cloudflare’s DNS again it started to fail again.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.