1.1.1.3 not blocking any adult content

Please include test result URL when you create a post in the community forum. Paste the results from → 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver

What is the issue you’re encountering

Despite changing Fritz!Box router settings to 1.1.1.3 (etc), no adult content is blocked

What steps have you taken to resolve the issue?

I have restarted my router.
I have checked the new DNS v4/v6 settings are still in place.
I have restarted my computer (Mac Sonama 14.5) and Safari.
I have “flushed” my DNS cache.
I have checked I am not running a “private relay”.
I have checked the Cloudflare malware and adult test sites: still accessible.

1.1.1.3 does of course work, subject to sites being categorised correctly. You can check by entering the site at https://radar.cloudflare.com

In your mac you can test by running dig example.com @1.1.1.3 and the response will be 0.0.0.0 for blocked sites.

Check your Mac is actually using your router as the DNS server and that the Mac and router aren’t using other resolvers or DoH or DoT.

Thanks very much for your reply.

Hi, in my MAC settings for my wifi network there are 3 DNS servers listed (not 1.1.1.3 or anything like that – fairly random looking numbers). However, they cannot be deleted (the minus sign is greyed out/doesn’t do anything). Is this the problem, and if so how can I solve it?

I guess I assumed all internet had to go through the router, so changing the DNS settings on that would be like a firewall or something for adult content (sorry, wrong terminology I know) and I could feel reasonably safe. If devices can (and do by default) just do their own thing, seems like a waste of time.

I have also tried adding the 4 Cloudflare v4/v6 malware and adult content DNS addresses to OSX settings>wi-fi>[network name]>details>DNS. This seemed to replace the IPs that were already there. I have also flushed the DNS cache again. But still nothing is blocked.

May I ask have you tried clearing your Web browser cache as well? :thinking:

Furthermore which Web browser are you using? For example in it’s Settings :gear: might be the DNS over HTTPS is enabled (Cloudflare by default - going through 1.1.1.1), meaning it’s bypassing the 1.1.1.3 configured in the Network Adapter (wired connection or WiFi).

1 Like

Hi Fritex, thanks for your suggestion. Indeed, after clearing my browser cache the blocking seems to work. However, I’ve now just tried the same in my browser’s private mode, and here nothing is blocked. What can I do about that?

I’m using Safari.