+ Android Automatic Private DNS = No Filtering


I noticed today that adult sites are no longer being filtered on Android. I double checked and the correct resolvers are set via DHCP. Then I noticed that Private DNS showed it was active. also confirms that DoT is being used. Setting Private DNS to off restored the adult filter. Can you please make sure that Android’s automatic DoT applies the same filtering that is specified by the DHCP resolvers?


I just noticed an issue with Android private DNS today. I am specifying via DHCP to my phones. With private DNS set to Automatic, I am able to access adult sites. Disabling private DNS resolves the issue. I did not have this same problem when testing on android several days ago.

Hi @bsnowden,

DNS over TLS support for is on the way, the setup instructions will be updated once released.

I don’t really care about private DNS. I care about the content filtering. The default for Android is automatic private DNS which causes content filtering to stop working even though the resolvers are set to Automatic private DNS should not be causing queries to go to instead of

:wave: @bsnowden

Android private DNS uses DoT which isn’t yet supported by

— OG

But it is available automatically now. That is the problem. Resolvers are set to Content filtering worked fine on Android once they started returning for blocked queries instead of refusing queries. Now all the sudden content filtering is not working because Android is activating private DNS where it previously did not with set. Cloudflare needs to make sure that Android does not enable private DNS to when resolvers are set to DoT would be nice to have to but until they get it working, they need to make sure Android does not detect dot as being available as it is currently automatically enabling dot to thus removing all content filtering.

Just curious if anyone is working on this issue as content filtering is still not working with because Android automatic private DNS is still activating to when resolvers are set to I am switching my home back to opendns family shield until this is resolved.