1.1.1.2 and 1.1.1.3 DoT TLS certificate error

Trying to use DoT (port 853) with 1.1.1.2 and 1.1.1.3 and I get the following certificate error:

2021/08/28 18:32:04 188505#17 [debug] github.com/AdguardTeam/dnsproxy/proxy.(*Proxy).udpHandlePacket(): error handling DNS (udp) request: talking to dnsUpstream failed, cause: Failed to get a connection from TLSPool to tls://1.1.1.2:853, cause: Failed to connect to 1.1.1.2, cause: x509: certificate is valid for 1.1.1.1, 1.0.0.1, 162.159.36.1, 162.159.46.1, 2606:4700:4700::1111, 2606:4700:4700::1001, 2606:4700:4700::64, 2606:4700:4700::6400, not 1.1.1.2

and

2021/08/28 18:32:56 189417#33 [debug] github.com/AdguardTeam/dnsproxy/proxy.(*Proxy).udpHandlePacket(): error handling DNS (udp) request: talking to dnsUpstream failed, cause: Failed to get a connection from TLSPool to tls://1.1.1.3:853, cause: Failed to connect to 1.1.1.3, cause: x509: certificate is valid for 1.1.1.1, 1.0.0.1, 162.159.36.1, 162.159.46.1, 2606:4700:4700::1111, 2606:4700:4700::1001, 2606:4700:4700::64, 2606:4700:4700::6400, not 1.1.1.3

It appears that .2 and .3 need new certs?

DoT is not yet supported for 1.1.1.2 and 1.1.1.3

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.