Warp Appears to Affect Grandstream Wave (VoIP) Android App

I have been testing various VoIP apps for Android and finally settled on Grandstream Wave. After disabling the SIP ALG helper on my router, I am able to make calls over my home Internet connection between two Android phones, a Galaxy S4 running Android 5.0.1 and a Galaxy S6 running Android 7.0. Warp is installed on the S6 but I disabled it while I got GS Wave working.

When I enabled Warp on the S6, GS Wave was able to authenticate with the SIP server but could not initiate a call to the S4 (“No response”). However, the S4 was able to initiative a fully functional call to the S6. I have an OpenVPN server on AWS - if I bring up OpenVPN on the S6, I have no issues with calls initiated either from the S4 or the S6, so tunneling the traffic through my home router and ISP should not be a problem.

Before dig into IP traces, has anyone else seen this issue? I have been running Warp on the S6 for almost a month and have not experienced any other issues. I see no issues based on cloudflare-dns.com/help.


Thanks, Norbert

Hi @nhoeller,

Can you share all the details you can via the :wbug: icon in the app?

Done. I posted to the Community because SIP communications seem to be particularly finicky where just the right combination of configuration settings are necessary.

Thanks, Norbert