1.1.1.1 isn't working

dash-dns
dns-resolver
#1

Hi,

I cannot seem to use your 1.1.1.1 DNS system, the reason being is because my Internet Service Provider keeps re-directing me back to my ISP’s DNS. When clearly I do NOT want to use my ISP’s I want to use your 1.1.1.1 DNS servers.

Could you please tell me what is going on with this on going problem?

#2

Have you tried 1.0.0.1? And how are you trying to get to 1.1.1.1 that’s redirecting you back to their DNS? Through a browser?

1 Like
#3

I’d start at Have problems with 1.1.1.1? *Read Me First*

2 Likes
#4

Hiya @sdayman and @sandro ,

This is what I am taking about please see the images down below:

I have set the DNS setting right haven’t I? But when I visit any “Who Is My DNS” website it re-directs me back to my ISP? I’d much perfer to use CloudFlare’s 1.1.1.1 service and not my ISP?

#6

You might also use https://1.1.1.1/help to test. It could be your ISP intercepts /redirect your DNS requests. If that’s the case you might investigate a tool like DNSCrypt.

1 Like
#7

Hiya @cscharff, Please inbox me with more information on this please?

#8

DNSCrypt will run an encrypted direct pipe from your computer to a DNS server. This should straighten it out.
https://www.dnscrypt.org/

2 Likes
#9

Hi @sdayman,

I would not have a absolute clue in what I will be doing to set it up, perhaps you can help me or are you busy?

#10

Actually, it is https://dnscrypt.info

dnscrypt.org has nothing to do with the project. I don’t know who’s operating it.

2 Likes
#11

Hi @jedisct1,

I’ve used the tool that you have mentioned DNSCrypt please see the screenshot .JPG images down below:

As you can see the images that the tool has worked and re-directed me DNS from my ISP to Cloudflare’s instead, well I can say @jedisct1 that your DNS tool that you have mentioned has worked & helped but one more question screenshot 3 and 4 is that the right IP address for Cloudflare or not?

#12

Those 141 addresses are definitely Cloudflare:

1 Like
#13

Yes, looks like it is working as expected.

1.1.1.1 is the IP address you connect to, but not the “real” IP address of the server. It’s an anycast address shared by many servers.

141.101.70.94 is the “real” (unicast) IP address of one of these servers and it definitely belongs to Cloudflare: https://api.iptoasn.com/v1/as/ip/141.101.70.94

So, you’re all set :slight_smile:

2 Likes
#14

Hi @sdayman, @sandro, @cscharff, @jedisct1,

Just like to let you all know that this has been 100% sorted, thank you so much for helping me all.

All the best! :smiley:

1 Like