1.1.1.1 is not resolving Office365 SMTP endpoints (servfail)

Good morning everyone!

I just noticed that 1.1.1.1 doesn’t seem to resolve A-records of Office365 tenants’ SMTP endpoints. Example:

image

Any ideas?

Is this still happening for you? I see this resolving fine worldwide:

http://dig.ping.pe/tesla-com.mail.protection.outlook.com:A:1.1.1.1

If you still see issues resolving, paste the nslookup output again and share a link from here;

https://1.1.1.1/help

Hi, Simon!

Thank you very much for getting back to me. This issue appears to be largely resolved in a sense that when I posted my message it was reproducible every single time I tried. Right now most queries are going through just fine, however a very small portion still fail. I leave it for you to decide if that’s something worth investigating, perhaps it is some sort of anti-abuse throttling mechanism at Cloudflare or within allowable failure rates.

Here’s my diag link – https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJJQUQiLCJpc1dhcnAiOiJObyIsImlzcE5hbWUiOiJDbG91ZGZsYXJlIiwiaXNwQXNuIjoiMTMzMzUifQ==

I used this script to query the same hostname numerous times and count failures:

$failures = 0

for ($i = 0; $i -lt 10000; $i++) {
    Write-Host $i -NoNewline
    try {
        Resolve-DnsName -Name "tesla-com.mail.protection.outlook.com" -Server 1.1.1.1 -Type A -DnsOnly -ErrorAction Stop | Out-Null
        Write-Host " ok"
    } catch {
        $failures++
        Write-Host " fail ($_)"
    }
    Clear-DnsClientCache
}

Write-Host "Total $failures failures"

Out of 10000 queries I got 11 failures – all servfails. Here’s one of the failed responses captured:

For the sake of experiment I ran the very same script but this time against google.com (as a target hostname, not Google DNS), and every single query out of 10000 was processed successfully.

Let me know what you think.

P.S. Even if I abuse your link for a little bit by hitting F5, eventually I see this:

Hi @emeliyanov,

Sorry for the issue, it should be fixed now. Please let us know if you still have any SERVFAIL. Thanks.

1 Like

Hi @anb!

Thank you for looking into this, I do confirm this is resolved now.