1.1.1.1 for families does not use DoH with Edge Chrome

https://1.1.1.1/help#eyJpc0NmIjoiWWVzIiwiaXNEb3QiOiJObyIsImlzRG9oIjoiTm8iLCJyZXNvbHZlcklwLTEuMS4xLjEiOiJZZXMiLCJyZXNvbHZlcklwLTEuMC4wLjEiOiJZZXMiLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMTExIjoiTm8iLCJyZXNvbHZlcklwLTI2MDY6NDcwMDo0NzAwOjoxMDAxIjoiTm8iLCJkYXRhY2VudGVyTG9jYXRpb24iOiJERlciLCJpc1dhcnAiOiJObyIsImlzcE5hbWUiOiJPcGVuRE5TLCBMTEMiLCJpc3BBc24iOiIzNjY5MiJ9

I have set my router to use 1.1.1.2 adn 1.0.0.2 for DNS. Firefox and Google Chrome will then use DoH with Cloudfare for families. However, Edge Chrome will not do DoH yet connects and resolves to Cloudfare. I have enabled DoH in Edge (
edge://flags/#dns-over-https ) I do not know what else to do or configure. Any assistance is appreciated.