1.1.1.1 doesn't resolve some domains ( but 8.8.8.8 works fine)


#1

Hi support,
We also have a domain name that isn’t resolving with 1.1.1.1 but it works perfectly fine when I use other DNS providers.

  • This domain name resolves in some regions (eg: US) but not others (Australia)
  • The TTL has always been set to 1 minute.

The zone is on DNSimple which previously had Respond from regions set to specific regions (Sydney, Australia was not enabled).

So I’ve since selected All Regions and waited for the TTL but it’s still not resolving.

Is there any way to get cloudflare dns 1.1.1.1 and 1.0.0.1 to refresh?

Has anyone ever encountered this before?

I have not deleted/recreated the record.

Default Server:  google-public-dns-a.google.com
Address:  8.8.8.8

> x.*********.com
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    x.*********.com
Address:  xxx.xxx.xxx.xxx

> server 1.1.1.1
Default Server:  1dot1dot1dot1.cloudflare-dns.com
Address:  1.1.1.1

> x.*********.com
Server:  1dot1dot1dot1.cloudflare-dns.com
Address:  1.1.1.1

Name:    x.*********.com

>```

apologies for not publicly disclosing this domain name!

#2

Just an update,

after waiting 3 hours and no change I solved the problem by deleting and recreating the record in DNSimple.

I think this was not a problem with cloudflare in the end.