1.1.1.1 can't resolve sharepoint.com subdomains

Again 1.1.1.1 is not able to resolve some domains, this time its subdomains of sharepoint.com
Can somebody from cloudflare please have a look?

C:\Users\error401>nslookup subdomain.sharepoint.com 1.1.1.1
Server: one.one.one.one
Address: 1.1.1.1

*** one.one.one.one can’t find subdomain.sharepoint.com: Server failed

1 Like

Can confirm the issue. Most of the time I received a SERVFAIL, sometimes with Iteration limit reached. Only in ~10% of all requests the query resolves fine.
➜ ~ dig .sharepoint.com @1.1.1.1

; <<>> DiG 9.10.6 <<>> <redacted>.sharepoint.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 18077
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;<redacted>.sharepoint.com.	IN	A

;; Query time: 54 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Nov 17 10:31:09 CET 2020
;; MSG SIZE  rcvd: 59

➜  ~ dig <redacted>.sharepoint.com @1.1.1.1

; <<>> DiG 9.10.6 <<>> <redacted>.sharepoint.com @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 29682
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 00 49 74 65 72 61 74 69 6f 6e 20 6c 69 6d 69 74 20 72 65 61 63 68 65 64 ("..Iteration limit reached")
;; QUESTION SECTION:
;<redacted>.sharepoint.com.	IN	A

;; Query time: 15 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Nov 17 10:31:14 CET 2020
;; MSG SIZE  rcvd: 88

Same problem here. 1.1.1.1 fails me, Google servers have no problem. Switched over now.

Can also confirm, having the same problem for multiple sharepoint domains. 1dot Cache purge has had no effect it seems.

I noticed the same issue too - started with intermittent resolution for companyname.sharepoint.com and strange behaviour within my OneDrive app.

Switched over to Google DNS and things have gone back to normal for me!

My bad, submitting a cache purge on 1dot for the sharepoint domain (both A and AAAA records) seems to help solve the issue for now- not sure if it will become inaccessable again.

I, too, am seeing this. I am using Cloudflare DNS in pihole and can consistently toggle the issue by switching DNS providers to/from Cloudflare. All others work ok.

In addition, as @MrPRSmith noted, I had an authentication issue on OneDrive which went away after moving away from Cloudflare DNS.

Sorry about this. It should be fixed now.

3 Likes

Yes, it is :+1: Just out of curiosity, can you tell the reason for the small outage?

It was an unexpected side effect when we were trying to mitigate attacks, queries were throttled in some high traffic area.

2 Likes